ServiceDesk 7.0 Licensing Error Messages and Troubleshooting Ideas

Article:HOWTO10655  |  Created: 2009-09-30  |  Updated: 2011-05-07  |  Article URL http://www.symantec.com/docs/HOWTO10655
Article Type
How To



Question
After installing ServiceDesk, I see the following error or errors.  What is the best way to troubleshoot them? 

Error 1:

     "License does not allow use of web part [SearchTextPortalWebPart]"

Error 2:

     "License does not allow use of web part [Inline|FrameView]"

Note: This KB applies to ServiceDesk 7.0 the equivilent KB for ServiceDesk 7.1 is.

ServiceDesk Licensing Error Messages and Troubleshooting Ideas
http://www.symantec.com/business/support/index?page=content&id=HOWTO50304

 

 Answer

  1. On the ServiceDesk server, verify that the Altiris user account is configured correctly.
     
    a. Stop IIS by going to a command prompt and typing IISRESET /STOP.
    b. Stop the LogicBase 2006 service in Windows Services.
    c. Go to Windows Start button > All Programs > Altiris > Workflow Designer > Tools > Notification Server Credentials Tool.
    d. Remove all credentials.
    e. Click on the Add button to add a new set of credentials. It is recommended to use the Altiris Application ID/Notification Server service account for the Notification Server 7 server. This is the same account that is referenced in Step 3.
    f. Fill in the fields in the New NS Credentials window. Note: Click on Default NS to enable this field if it is not already checked.
    g. Click on the OK button.
    h. Click on the Test button. If this fails, re-enter the credentials as some value is invalid. For the Machine Name or IP Address field, if these steps do not work, retry these with variations for this field, such as the host name only, FQDN, or IP address. Note: The Test button validates that the user/password successfully authenticates to the Notification Server. This is not in itself a valid license test.
    i. After the Test button works, close the Notification Server Credentials Manager and any Workflow Designer that may be open. Note: Closing this window may take a few minutes and may not respond during this time. This is normal.
    j. Restart IIS by going to a command prompt and typing IISREST / START
    k. Start the LogicBase 2006 service in Windows Services.
     
  2. On the Notification Server, verify that it is reporting the ServiceDesk licenses correctly.

    a. Go to Start > Administrative Tools > Internet Information Services (IIS) Manager.
    b. Go to <server_name> > Web Sites > Default Web Site > Altiris > ServiceDesk.
    c. Right click on Licensing.asmx and choose Browse.
    d. Click on GetLicenseCount.
    e. Click on the Invoke button.
    Note: The license amount will then appear as "int xmlns="http://www.altiris.com/servicedesksolution70/licensing">1</int>, with the "1" being the number of licenses. This needs to be at least 1.
     
  3. On the Notification Server, verify that the account used by Step 1 is configured as a Symantec Administrator.

    a. In the Altiris Console, click on Settings > Security > Roles.
    b. Click on the Symantec Administrators group.
    c. If the account from Step 1 is not part of this group, add the user to it.
     
  4. On the Notification Server, verify that the license is in Symantec Installation Manager (SIM) and is not expired.

    a. If the license was recently installed, restart the Altiris service for the change to take effect. If this cannot be done, wait 30 minutes for this to recycle automatically.
    b. Remove and reinstall the ServiceDesk license, ensure that this is available on the hard drive beforehand. This can be done by using the License Removal Tool on the Notification Server, found at <installation_drive>\Program Files\Altiris\Notification Server\bin\Tools\RemoveLicenses.exe. Remove all of the ServiceDesk-related licenses. Use Symantec Installation Manager (SIM) to re-apply only the production-type licenses. Do not re-apply any of trial license.
    c. Note: If the license is still not working after checking the Licensing.asmx file, the Altiris Application ID, and then license in SIM, then there may be a core Notification Server license issue which may next need to be advanced to the Notification Server team for additional assistance.
     
  5. On the ServiceDesk server, verify that the Notification Server Credentials tool is reporting licenses correctly. 

    a. Go to the Windows Start button > All Programs > Altiris > Workflow Designer > Tools > License Status Manager.
    b. Click on the Run Tests button. Note: Certain Run License Tests will fail, this is normal.
    c. Click on the Application Licenses tab. Note: The results for the Installed Applications may take a few moments to load.
    d. The license amount will appear in LicenseCount. This number should match the number from step 2e.
    e. Verify that the Notification Server credentials are entered correctly in the Notification Server Credentials Tool. 
     
  6. If you've gone through this HowTo and the licensing.asmx page on the Notification Server returns the proper licensing count,  you'll want to check and see if there are licensing errors such as the following in the logicbase.serverextenstions.log:

    Error,Monday, January 31, 2011 11:02:55 AM,Connection failed. Returning no license present. Please check your Notification Server settings. System.Net.WebException: The remote server returned an error: (500) Internal Server Error.
       at System.Net.HttpWebRequest.GetResponse()
       at SD.Licensing.ServiceDeskLicensingClient.ServiceAvailable()

    If you do see these errors then the credentials specified in the Notification Server Credentials tool are being rejected.To correct this, open the Notification Server Credentials Tool and edit the machine name to IP or Netbios name, the Domain from FQDN to Netbios name and verify the User name and password. 

  7. Environmental issues may also cause licenses to fail to work, such as not being able to communicate with the Notification Server, low resources on the ServiceDesk server, network latency, DNS issues, etc. Check the logicbase.serverextensions log in the <ServiceDesk_installation_drive>:\Program Files (x86)\Altiris\Workflow Designer\Logs folder for license errors. If license errors are still occurring in this log after all of the above steps have been performed, if possible, reboot the ServiceDesk server and also the Notification Server to see if this helps. If not, then there may be more serious environmental issues occurring that are the root cause.

Related Resources

Can Helpdesk 6.0 licenses be used with ServiceDesk 7.0, or ServiceDesk 7.0 licenses uses with Helpdesk 6.0?
http://www.symantec.com/business/support/index?page=content&id=TECH44715

 

ServiceDesk 7.1 Licensing Error Messages and Troubleshooting Ideas
http://www.symantec.com/business/support/index?page=content&id=HOWTO50304


Legacy ID



49372


Article URL http://www.symantec.com/docs/HOWTO10655


Terms of use for this information are found in Legal Notices