How can we configure to use Helpdesk database for a custom Altiris report to query?

Article:HOWTO10886  |  Created: 2009-11-25  |  Updated: 2012-07-28  |  Article URL http://www.symantec.com/docs/HOWTO10886
Article Type
How To


Question

You can create new reports on incidents by editing the SQL directly, but there are also options to get help creating the report as a

Simple report, Summary Report and Advanced Report Builder.

When I try to use the Simple Report option and go to select a Data/Resource Type the options I get look like they are to do with asset management, rather than the Incidents.

How can we configure which database is used for a custom Altiris report to query?

For instance, I can't find anything that looks like an Incident or a Work Item.

How can we configure which database is used for a custom Altiris report to query?

If we can have incidents related items here? 

Answer
Report Builder should display objects that starts with 'HD_'. Those views are placed by Helpdesk on the Altiris database so you can query information from the Incidents database.

The Report Builder will look at the Altiris database tables and not to the Incidents database tables directly. But as I mentioned, Helpdesk should create views that starts with 'HD_' on the Altiris database.

The report builder should show those views that are generated by helpdesk into the Altiris database. They should be more familiar in how to generate reports using those tables or how to point to the right place for helpdesk items when using the report builder.

Sometimes you may get error message described in KB 26172; it is very common error that is related to rebuilding metadata used for the report builder.


NB! It does not appear as though those data types are available using the Simple Report.

It just does not look like the functionality was created using the Simple Report or the Summary Report to connect to the incident tables that begin with HD_. In the Simple or Summary Reports, it is asking them to pick a data type.  There are no datatypes specified for Helpdesk on the Altiris Database and therefore you do not see them there. 

 The ONLY way to pull Helpdesk info into a report is by using Advanced Report Builder or Enter SQL Directly.

Note: One of the customers following our advice, tried to use the Advanced Report Builder now but there are no “HD_” type objects showing in list. It looks like you may need to re-apply the database in the incident settings. This is the process that builds those views. Please re-apply the database and see if that fixes this issue.

To do so:

Please go to Configuration - Server Settings - Notification Server Settings -Incident Settings, check the connection by pressing Test Connection button, make sure that correct SQL server and database shown and hit Apply button.

If you get confirmation request please press Ok to proceed this will re-apply Incident database.


Legacy ID



50325


Article URL http://www.symantec.com/docs/HOWTO10886


Terms of use for this information are found in Legal Notices