Inventory Solution for Windows detecting incorrect version of Lotus Notes s/w
| Article:HOWTO1759 | | | Created: 2006-01-19 | | | Updated: 2006-01-19 | | | Article URL http://www.symantec.com/docs/HOWTO1759 |
Problem
After running a software inventory and examining under the 'Inventory' tab in Resource Manager, the "AeX SW Lotus Notes" data class in Resource Manager, detects the version via the file, nminder.exe. However, this is one of the utility files in Lotus Notes s/w. Rather, the nlnotes.exe file should be captured instead. As a result, wrong version is being captured. This is because although the nlnotes.exe shows that the version is 6.5.20.4139, the nminder.exe shows that the version is 6.0.0.0.
Environment
Altiris Inventory Solution 6.0
Cause
The default configuration for the "AeX SW Lotus Notes" data class is as follows:
Product Name=Lotus Notes
Product Name=NOTES
This is applicable for the nlnotes.exe and nminder.exe.
Resolution
Be more specific in the Special groups properties to capture the correct file:
(1) Navigate on your NS to:
<Install Path>\altiris\Notification Server\NSCap\Bin\Win32\X86 and open AeXAPedit.exe
(2) Go to File->Open and open auditpls.ini under <Install Path>\altiris\Notification Server\NSCap\Bin\Win32\X86\Inventory Solution
(3) Navigate to the Special Groups tab
(4) Double click on AeX SW Lotus Notes and add an attribute Filename, put the value of the filename the file that has the correct versioning (You can browse for it if you are running this from a client)
(5) Remove the two original entries, i.e.
Product Name=Lotus Notes
Product Name=NOTES
(6) Exit the utility saving your changes and then test by updating config on your client and running the Software Inventory again.
Legacy ID
18223
Article URL http://www.symantec.com/docs/HOWTO1759
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