How to create a Transform

Article:HOWTO3813  |  Created: 2006-06-09  |  Updated: 2007-12-27  |  Article URL http://www.symantec.com/docs/HOWTO3813
Article Type
How To



Question
How Do I Create a Transform ?

Answer

Notes:

-You cannot install a transformed .MSI over a transformed .MSI.  Uninstall the first transformed package from the machine prior to installing the new .MSI and transform.

-You cannot use InstallTailor™ to create a transform for an application that is already installed on your computer. Uninstall the application before running InstallTailor.  

In Wise Installation Studio (For Wise Package Studio see below):

1. Select File menu > New. The New Installation File dialog appears. (In Visual Studio: select File menu > New > File. The New File dialog appears.)

-From the Categories list, select Other Templates. (In Visual Studio: select Wise Files.)                                  
    In the Templates/Tools list, select the Transform icon, then click OK. (In Visual Studio: in the Templates list,
    select Transform File, then click Open.) The Open File dialog appears.
2. Specify the .MSI on which this transform should be based.

The transform opens with the exact settings of the installation on which it is based.

3. Make changes to the installation, such as adding files, or changing any other settings.

Note

If you add files when editing a transform, a .CAB file is created along with the transform. When you apply the transform, make sure the .CAB file, the original .MSI, and the .MST are all in the same directory.


4. When you finish making changes, select File menu > Save.
     The Save As dialog appears. (In Visual Studio: the Save File As dialog appears.)
5. Type a name for the transform and click Save.   The Transform Details dialog appears.
6. Complete the Transform Details dialog


For Wise Package Studio:


1. Do one of the following:

-On the Projects tab, click the Run link to the right of the task or tool associated with InstallTailor. This tool might skip dialogs or populate fields based on command line options defined in Process Templates Setup.

-On the Tools tab, double-click InstallTailor. 

The Welcome dialog appears.

2. Complete the dialog:

-Windows Installer package

Specify the installation file (.MSI) or transform file (.MST) to create a transform for.

-Base MST file

Specify a transform to apply to the installation.

3. Click Next.

If you specified a transform file, you might be prompted to specify the base .MSI, if that information is not embedded in the transform.

The installation runs in a simulated mode.

4. Step through the installation and make changes to save in the transform. The resulting transform, when applied to the base installation, will make the same changes that you make during this simulated installation.

5. If the Hide Dialog checkbox is available on a dialog, mark it to hide that dialog from the end user during installation. This ensures that changes you make on the dialog cannot be overridden by the end user.

This checkbox does not appear on complex, custom dialogs, or for certain installations that do not support it.

6. When you complete the simulated installation, a message appears indicating that changes to the installation have been captured. Click OK.

The Capture Complete dialog appears.

7. Complete the dialog:

If you are working with a process, Transform file name is set to [ProjectDir]\[ProjectName].mst, and Shortcut name is set to [ProjectName].

-Transform file name

Specify the name and location for the new transform file (.MST).

If you launched InstallTailor from the Projects tab, this field might not be editable.

-Shortcut name

Enter the name of the shortcut to run this transform file with the base installation. This defaults to the Transform file name specified above.

If you launched InstallTailor from the Projects tab, this field might not be editable.

-Edit this transform file using Windows Installer Editor

Mark this to make changes to the transform that were not possible in InstallTailor. If you mark this, the transform file opens in Windows Installer Editor after you click Finish.

If you launched InstallTailor from the Projects tab, this checkbox might not appear.

8. Click Finish on the Capture Complete dialog.

The .MST and shortcut are created in the location you specified or in the current project's directory. Double-clicking the shortcut applies the transform to the base installation.


Legacy ID



23556


Article URL http://www.symantec.com/docs/HOWTO3813


Terms of use for this information are found in Legal Notices