Barcode field data may be lost after Inventory to Asset Synchronization and Duplicate Computer Merge

Article:HOWTO4709  |  Created: 2006-08-22  |  Updated: 2011-01-19  |  Article URL http://www.symantec.com/docs/HOWTO4709
Article Type
How To



Problem
 

Under certain conditions, when the Duplicate Computer Merge task is run after the Inventory to Asset Synchronization task, barcode field data may be lost.

Environment
Notification Server 6.0
Asset Control 6.2

OR

CMDB 6.5

Cause
 

Barcode field data may be lost if the following has occurred:

 

  1. A computer resource, computer A, is entered into Notification Server via Asset, Barcode, or Connector, including the system number and barcode data in the Inv_Identity data class.
  2. The same computer is placed on the network and the Inventory Agent is installed.
  3. The hardware inventory task is run, collecting the Serial Number and Asset Tag from the computer and creating a new computer resource, computer B, in Notification Server with this information in the Inv_AeX_HW_Serial_Number table.
  4. The Inventory to Asset Synchronization task runs (see article 34392 for more information), updating the Inv_Serial_Number.[Serial Number] field of computer B with the data from the Inv_Aex_HW_Serial_Number.[Serial Number] field and the Inv_Identity.[System Number] field of computer B with the data from the Inv_AeX_HW_Serial_Number.[Asset Tag] field.
  5. The Duplicate Computer Merge task runs. Because step 4 is run later than step 1, the Inv_Identity table of computer B now has the latest date/time stamp and only computer B's Identity class information is preserved in the resulting merged resource, meaning that the barcode from computer A's Identity class has been lost because the barcode field is also contained in the Identity class.

Resolution
 

To work around this issue, you may choose to implement the following workaround.

Warning: Implementing this will prevent the automatic update of System Numbers from Asset Tag Inventory data, thus you would only be able to merge on Serial Number, using the Duplicate Computer Merge rule, after making this change.

Note: Repairing or upgrading Asset Management Solution 6.x will reverse this change so these steps would need to be redone.

 

 

You will need to comment out the System Number SQL code block within the spAssetInventorySync stored procedure. Block comments are done by putting this /* before the block of SQL and this */ after it:

  1. Be sure to have a database backup before proceeding.
  2. In SQL Server 2005, find the spAssetInventorySync under your Altiris database > ProgrammabilityStored Procedures folder.
  3. Right-click the spAssetInventorySync stored procedure and click Modify; a new query analyzer window opens with the ALTER PROCEDURE [dbo].[spAssetInventorySync] code.
  4. To remove the field - Inv_Identity.[System Number] - comment out the following:

    execute @ReturnCode = spAssetInventorySync
         'BF9737CD-DAC9-4D59-BD7A-B6B57A9A7409',
         'CFBB6C2E-5240-4CF5-A764-868A44DF708B',
         'Asset Tag',
         'System Number',
         null,
         @includeCollectionGuid,
         @excludeCollectionGuid

5. Execute the new ALTER PROCEDURE [dbo].[spAssetInventorySync] code.

Additional Troubleshooting

If these instructions fail to resolve the issue, this may be a related but different issue, documented here:

KNOWN ISSUE: Resources created in the receiving console screen lose data when merged
http://www.symantec.com/business/support/index?page=content&id=TECH20590



Legacy ID



25979


Article URL http://www.symantec.com/docs/HOWTO4709


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