Case Intrusion detected on Dell computers

Article:HOWTO5625  |  Created: 2006-10-30  |  Updated: 2008-04-23  |  Article URL http://www.symantec.com/docs/HOWTO5625
Article Type
How To


Problem
Case Intrusion on Dell* computers are being detected, even when no such intrusion has occurred recently.

Environment
Dell Client Manager 2.0, 2.1
Dell Computers with Chassis Intrusion turned on in the BIOS

NOTE:  DCM 2.2 addresses this without the need to use the attached policies.

Cause

Intrusion detection is logged in the BIOS of the computer. When Dell's OMCI checks for a chassis intrusion, it doesn't look at the date of the intrusion nor does it take into account that it has previously reported the error. Therefore, as long as error messages from OMCI are not trapped by DCM the error will continue to appear at intervals of approximately 15 minutes.

Resolution
There are two possible solutions. Because this error appears to be generated at a very low level, actually enabling intrusion detection in the Dell Monitoring policy on the Notification Server should actually resolve this as code in the policy should intercept these warnings.

If this fails to address the problem, a second, more involved resolution is described below. This is to be done on the Notification Server. This example is shown for a computer running a Win 32-bit operating system. If Notification Server was installed to a non-standard location, use that location instead. 

Note: Users are encouraged to look over the included XML to determine if there may be potential problems applying this to their systems. If Notification Server was installed to a non-standard location the XML files will need to be updated to use the correct path. Important: The import process requires that a file have ANSI encoding. When saving the file in Notepad*, use the Save As option and change the encoding from the default of UTF-8 to ANSI.

Dell Client Manager 2.0

  1. Download DisableChassisIntrusion2_0.zip and extract it to a local folder.
  2. Copy C:\Program Files\Altiris\Dell Client Manager\ClientUtilities\X32\OmcaClientModule32.exe to C:\Program Files\Altiris\Notification Server\NSCap\Bin\Win32\X86\DellCM Discovery Agent.
  3. Copy C:\Program Files\Altiris\Dell Client Manager\Schema.xml to C:\Program Files\Altiris\Notification Server\NSCap\Bin\Win32\X86\DellCM Discovery Agent.
  4. Copy DisableOMCINotifications.xml, that was extracted in step 1, to the C:\Program Files\Altiris\Notification Server\NSCap\BIN\Win32\X86\DellCM Discovery Agent.
  5. Navigate to the Console > Configuration > Solution SettingsPlatform Administration > Dell Client Manger tab on the NS console.
  6. Right-click on the Dell Client Discovery Rollout folder. Select the import option. Select the Dell Client Discovery Package.xml extracted in step 1 and import the file.
  7. Once again, right-click on the Dell Client Discovery Rollout Folder. Select the import option. Select the Disable OMCI Notifications Policy.xml extracted in step 1 and import the file.
  8. To confirm points are properly updated, select the Dell Client Discovery Package node and press the Update Distribution Points button.
  9. Enable the newly imported/created Disable OMCI Notifications policy

Dell Client Manager 2.1

  1. Download DisableChassisIntrusion2_1.zip and extract it to a local folder.
  2. Copy C:\Program Files\Altiris\Dell Client Manager\ClientUtilities\X32\OmcaClientModule32.exe to C:\Program Files\Altiris\Notification Server\NSCap\Bin\Win32\X86\Dell Client Manager\Discovery Agent.
  3. Copy C:\Program Files\Altiris\Dell Client Manager\Schema.xml to C:\Program Files\Altiris\Notification Server\NSCap\Bin\Win32\X86\Dell Client Manager\Discovery Agent.
  4. Copy the attached file DisableOMCINotifications.xml to the C:\Program Files\Altiris\Notification Server\NSCap\BIN\Win32\X86\Dell Client Manager\Discovery Agent.
  5. Navigate to the Console > Configuration > Solution SettingsPlatform Administration > Dell Client Manger tab on the NS console.
  6. Right-click on the Dell Client Discovery Rollout folder. Select the import option. Select the Dell Client Discovery Package.xml extracted in step 1 and import the file.
  7. Once again, right-click on the Dell Client Discovery Rollout Folder. Select the import option. Select the Disable OMCI Notifications Policy.xml extracted in step 1 and import the file.
  8. To confirm points are properly updated, select the Dell Client Discovery Package node and press the Update Distribution Points button.
  9. Enable the newly imported/created Disable OMCI Notifications policy

As this new policy is run on the clients, it should disable all Dell OMCI notification windows and policies.

Although this should not be necessary, as a final work around, disabling Intrusion Detection in the BIOS (either manually or via DCM) should eliminate these notifications.

Legacy ID



29004


Article URL http://www.symantec.com/docs/HOWTO5625


Terms of use for this information are found in Legal Notices