Comparing Windows Installer files using Visual MSIDiff

Article:HOWTO5789  |  Created: 2006-11-17  |  Updated: 2007-08-23  |  Article URL http://www.symantec.com/docs/HOWTO5789
Article Type
How To



Question
Comparing Windows Installer Files

Answer

Comparing Windows Installer Files

Visual MSIDiff* lets you compare the following types of files and see the differences in Setup Editor > Tables tab: .msi, .wsi, .msp, .msm, .wsm, or .mst files. You can compare an .msp file only with its base .msi.

Options for Comparing Files

  • Compare the current file to another file.
  • Compare any two files. (Not available in the Visual Studio integrated editor.)
  • Compare a transform to its base .msi, to see the items that the transform changes in the .msi.

To view differences between two Windows Installer files:

  1. Open a file.
  2. Select the Tools menu > Visual MSIDiff and then select an option. (In Visual Studio: Project menu > Visual MSIDiff.)
    • Compare Current File to Another File
      The Compare Windows Installer Files dialog appears. Specify the file to compare to the current file. To have the file you specify in Compare To treated as the newer file in the comparison, mark the dialog's check box. To compare an .msp to an .msi, the current file must be the .msi. An .msp is always treated as the newer file. Click OK.
    • Compare Any Two Files
      The Compare Windows Installer Files dialog appears. Specify the files to compare. The file you specify in the Base File field becomes the current file. To compare an .msp to an .msi, the Base File must be the .msi. To have the file you specify in Compare To treated as the newer file in the comparison, mark the dialog's check box. An .msp is always treated as the newer file. Click OK. (Not available in the Visual Studio integrated editor.)
    • Compare Transform to Base .MSI
      (Transform files only.) Automatically compares the .mst to its base .msi.

      You are taken to Setup Editor > Tables tab and the Visual MSIDiff Key dialog appears, which describes icons that indicate changes. Changes are shown in the tables and rows where they occur.
  3. On the Visual MSIDiff Key dialog, take note of the symbols and colors that indicate changes and click OK.

    If the Visual MSIDiff Key dialog does not appear, you might have marked its Do not show this dialog again check box. You can reactivate this prompt in Wise Options.
  4. Scroll through tables on the Tables tab, looking for the symbols for changed tables. Click on changed tables to view differences in rows, which are indicated by symbols and colors.

    As you work in the installation file, the symbols indicating changed items are updated dynamically. The compare stays on until you end it.
  5. To end the compare, select Tools menu > Visual MSIDiff > End Current Compare. (In Visual Studio: Project menu > Visual MSIDiff > End Current Compare.) This turns off compare symbols and closes the comparison file.

Legacy ID



29528


Article URL http://www.symantec.com/docs/HOWTO5789


Terms of use for this information are found in Legal Notices