Prerequisites for the Compliance Accelerator server computer

Article:HOWTO58539  |  Created: 2011-08-01  |  Updated: 2013-07-12  |  Article URL http://www.symantec.com/docs/HOWTO58539
Article Type
How To


Subject


Prerequisites for the Compliance Accelerator server computer

Table: Prerequisite software for Compliance Accelerator server installation lists the software items that you must install and configure on the computer that is to run the Compliance Accelerator server software.

Table: Prerequisite software for Compliance Accelerator server installation

Item

Notes

Windows

You require one of the following:

  • Windows Server 2008 R2 x64 Edition, original release or SP1.

  • Windows Server 2012.

On computers where you want to install the optional Support for Crystal Reports website, do the following before you start the installation:

  • Temporarily turn off User Account Control (UAC). If you do not do this, you receive error messages when you install the website.

  • Restart the computer.

We recommend that you disable the Windows Search Service to stop it from interfering with the progress of Compliance Accelerator export runs.

See Disabling the Windows Search Service on the Compliance Accelerator server.

Internet Information Services (IIS)

You require IIS 7.5 or later with ASP.NET, IIS 6.0 Management Compatibility, and Windows Authentication.

Internet Explorer

You require Internet Explorer 7.0 or later to run the Accelerator Manager website and Support for Crystal Reports website.

For optimum results, do the following:

  • Configure the privacy settings in Internet Explorer to allow cookies.

  • Turn off any pop-up blockers.

  • Ensure that the advanced option Play animations in webpages is selected.

    In Internet Explorer, click Internet Options on the Tools menu. Then, on the Advanced tab, locate the required option in the Multimedia category.

Internet Explorer Web Controls

The installation package for these controls is in the Links To Related Software folder on the distribution media.

Some versions of Windows may display the message "This program has known compatibility issues" when you install the Internet Explorer Web Controls. You can ignore this message, as the Web Controls should still install without problem.

Outlook

You require one of the following so that client users can export Exchange Server items in PST format and download the original versions of the items:

  • Outlook 2003 SP2 or SP3.

  • Outlook 2007 SP2.

Add the AttachmentMax and RecipientMax values to the registry on the Compliance Accelerator server to avoid problems when processing items that have many attachments or many recipients.

See Configuring Outlook to enable the processing of items with many attachments or many recipients.

Enterprise Vault

If Compliance Accelerator is installed on a separate computer from Enterprise Vault, you must install the Enterprise Vault software on the Compliance Accelerator computer.

As a minimum, you require a 9.0 or 10.0 version of one of the following:

  • Enterprise Vault Services

  • Enterprise Vault API Runtime

There is no need to configure Enterprise Vault after you have installed it on your Compliance Accelerator server computer; do not run the Enterprise Vault configuration wizard. In addition, if the Enterprise Vault Admin service is running on your Compliance Accelerator server computer, we recommend that you stop it and set its startup type to Disabled.

 

Note the following important points about the version of Enterprise Vault that you install on the Compliance Accelerator server:

  • All Enterprise Vault servers in all Enterprise Vault sites in a Compliance Accelerator environment must run the same version of Enterprise Vault.

    For example, when using Compliance Accelerator with two Enterprise Vault installations, you cannot have one site that runs Enterprise Vault 9.0 and another that runs Enterprise Vault 10.0.

  • The major version of Compliance Accelerator must be the same as, or one later than, the major version of Enterprise Vault.

    For example, you can run Compliance Accelerator 10.0 with Enterprise Vault 9.0 servers, but you cannot run Compliance Accelerator 9.0 with Enterprise Vault 10.0 servers.

  • If the major version of Compliance Accelerator is the same as the major version of Enterprise Vault, the minor version (Service Pack) of Compliance Accelerator must be the same as, or later than, the minor version of Enterprise Vault.

    For example, you can run Compliance Accelerator 10.0.4 with Enterprise Vault 10.0.3 servers, but you cannot run Compliance Accelerator 10.0.3 with Enterprise Vault 10.0.4 servers.

  • When upgrading both Compliance Accelerator and Enterprise Vault, you must first upgrade Compliance Accelerator, then Enterprise Vault on the Compliance Accelerator server, and finally Enterprise Vault on the Enterprise Vault server.

See the Compatibility Charts for more information on supported versions of Enterprise Vault.

To search on content with Compliance Accelerator, set indexing on the Enterprise Vault archives to full.

Windows Installer

You require Windows Installer 3.1 or later. The installation package for version 3.1 is in the Links To Related Software folder on the distribution media.

.NET Framework

You require .NET Framework 3.5 SP1 or later.

This is available as a separate download (see the Links To Related Software folder in the distribution media).

We recommend that you do not configure the Compliance Accelerator server to download and install .NET Framework updates automatically from the Windows Update site. Contact Symantec Support before installing such updates.

Lotus Notes client

You require version 8.5.2, 8.5.3, or 9.0 of the Lotus Notes client so that client users can export Lotus Domino items.

Install the client in single-user mode, using the account under which the Accelerator Manager service runs.

Visual C++ 2008 SP1 Redistributable Package (x86)

Enterprise Vault installs a suitable version of this package. The installation files for the package are also in the Links To Related Software folder on the distribution media.

ADSI Edit

If you plan to create Compliance Accelerator employee groups using Active Directory accounts, you need to know the LDAP path to the Active Directory group containers. The Active Directory Service Interfaces Editor (ADSI Edit) lets you find out the ADsPath of a container.

On a computer that is running Windows Server 2008 R2, ADSI Edit is installed when you install the Active Directory Domain Services (AD DS) role to make a server a domain controller. You can also install the Windows Server 2008 Remote Server Administration Tools (RSAT) on domain member servers or standalone servers. For instructions, see http://go.microsoft.com/fwlink/?LinkId=143345.

Do not alter any Active Directory entries with ADSI Edit. If you do so and make a mistake, you may cause serious problems that require you to reinstall Windows.

For the best results, we recommend that you install the Compliance Accelerator server software on a computer that has the following:

  • 64-bit architecture.

  • At least 4 GB of memory.

  • Sufficient hard drive space to accommodate the searches and export runs that you expect to undertake.

    All transaction requests from Compliance Accelerator clients to the Enterprise Vault and Compliance Accelerator servers use the Temp folder of the Vault Service account for temporary storage. Therefore, you must ensure that this folder has sufficient free space to handle large Compliance Accelerator searches and export runs. On both the Compliance Accelerator and Enterprise Vault servers, the Vault Service account's Temp folder must be on a drive that has a minimum of 40 GB of free space. However, 80 GB of free space is preferable.

    Exclude the Vault Service account's Temp folders from antivirus scanning.

  • Multiple hard drives. For example, you might use drive C for the operating system, drive D for the CD or DVD drive, drive E for the Temp folder of the Vault Service account, and drive F for the export output folder. You might split the Windows paging file across drives E and F.

See Prerequisites for Journaling Connector computers

See Prerequisites for the SQL Server computer

See Prerequisites for Compliance Accelerator client computers

See Installing the Compliance Accelerator server software


Legacy ID



v17845531_v41328187


Article URL http://www.symantec.com/docs/HOWTO58539


Terms of use for this information are found in Legal Notices