Changed Domains and need to change to the new domain in Helpdesk

Article:HOWTO6478  |  Created: 2007-01-22  |  Updated: 2010-12-13  |  Article URL http://www.symantec.com/docs/HOWTO6478
Article Type
How To


Problem
The domain for the network has been changed and now the users in Helpdesk need to be changed.

 

 

Note: This resolution is to be done before the new domain is imported into NS.

Environment
Helpdesk 6.x

Cause
The Domain has been changed for the network.

Resolution
 

NOTE:  This resolution needs to be done before the new domain is imported into the NS server.

To update the domain you will need to have Connector Solution installed on your Notification Server. Once Connector Solution is installed, here are the steps you will need to do:

1. Disable the rules to import users through the Active Directory Connector.
2. Disable selfenrollment. Follow instructions given in:

What do I need to do to disable self enrollment on Helpdesk?
http://www.symantec.com/business/support/index?page=content&id=TECH32209

3. Browse to the Connector solution:
    For Connector 6.5, go to Configuration\Solution Settings\Connectors
    For older versions of Connector, go to Configuration\Server Settings\Notification Server Infrastructure\Data Replication
4. For Connector 6.5, Under Connectors you will need to setup a data source.

    For older versions of ConnectorUnder Data Replication you will need to setup a data source.

 
5. Setting up the Data Source for this example we used an Oledb connection.  Here are the example settings:

            Name: Use something so you will know what the data source is used for (example: Domain Change)

            Data Source Type: MS SQL Server Database

            DB Server Name: SQL server containing the database you need to change the domain on.

            User Id and Password:  User that has permissions to make the change to the database like Application Identity.

            DB Name: Name of the Altiris Database

            Table Name:  -Specify Import Query-

            Import Query:  Here is an example query where you add the new domain name:

 

        Select u.guid, domain, 'New Domain' as NewDomain

        from vUser u
       
where domain = 'Old Domain'           Check the box for Allow Imports and then Save the Data Source

 


6. Setup the Import/Export rule. Here are example settings:

          Name: Use something so you will know what the data source is used for (example: User Domain Change)

          Data Source:  Point it at the Data Source you just created.

          Resource Type: User

          Replication Direction: Import

         Check Allow Resource Update. (Most likely you won't want to select create as you are pulling the data from the current database)

         Resource Lookup Key:  If using a query like my example set the Resource Lookup Key to be the Guid.

         Column Mappings:  Set the Resource Name to Resource_Name. 

         Set the mapping for the Domain under the Global Windows Users Section to the column of New Domain.  Then save the Import/Export rule.

 

7.  Test the Rule. If you get the expected results, go ahead and execute the rule.

8. Check the User to see if the domain was updated.

9. Go to http://<server_name>/aexhd/auto.asmx and click on AutoUpdate.

10. Under the new window click on the Invoke button (this will run the sync between Helpdesk and NS).

11.  Check in Helpdesk to see if the domain is updated in Helpdesk. (if it has not updated but is updated in NS re-run the Autoupdate)

12. Create and enable Active Directory Connector rules for the new domain.



Legacy ID



32106


Article URL http://www.symantec.com/docs/HOWTO6478


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