How to configure a Task Server when the agent on the Notification Server has been redirected

Article:HOWTO6897  |  Created: 2007-03-07  |  Updated: 2007-05-15  |  Article URL http://www.symantec.com/docs/HOWTO6897
Article Type
How To



Problem

This article deals with the following two environments:

  1. Reporting Notification Server's are being managed via a single Forwarding Notification Server.
  2. Package Replication Solution is being used in order to have some hierarchical functionality. 

Both environments require you to redirect the Altiris Agent to a different Notification Server.

Once this scenario has been setup, the a.log files will start to be populated by errors and warnings pertaining to the "Client Task Agent" failing to register with the Task Server. 

Environment
Notification Server 6.0.6074
Task Server 6.0.x

Cause

When you install the Task Server product onto your Notification Server via Solution Center, the installation also installs the following agents to the Altiris Agent environment, thus making the Notification Server the first Task Server in your infrastructure:

  • Altiris Client Task Server (creates the following two services:  'Altiris Client Task Data Loader' & 'Altiris Object Host Service')
  • Altiris Client Task Agent (Task Server Agent that runs the communications between the Task Server and the Altiris Agent)
  • Altiris Power Management Agent
  • Altiris Script Task Agent
  • Altiris Service Control Task Agent

If the Altiris Agent on the Notification Server has been redirected, then the "Altiris Client Task Agent' will be unable to register with its Task Server, causing it to record errors and warnings in the a.log/agent.log file.

Resolution
For Task Server to function in such an environment, do the following:

  1. Remove the following agents from the Notification Server via Add or Remove Programs so as to prevent these errors and warnings from occurring:
    • Altiris Service Control Task Agent
    • Altiris Script Task Agent
    • Altiris Power Management Agent
    • Altiris Client Task Agent
  2. Create at least one remote Task Server by running through the necessary steps within the Console.
  3. Restart the Notification Server Agent service on any computer that already has the "Altiris Client Task Agent," which is being managed by this Notification Server, so as to force the 'Altiris Client Task Agent' to register with the new Task Server.

This allows Task Server to be used in this type of environment but prevents it from taking advantage of the 500 nodes that the Notification Server could service if it was a Task Server.

One thing that needs to be done once Task Server has been installed onto the Notification Server is to change the Collection that the Task Server > Agent Configuration policy points to, so as not to cause any warnings from being created in the agent.log files. By default, it points to the All Computers Collection, but logically it should point to the With Client Task Agent Installed Collection.

The following agents can now be deployed from the Parent Notification Server to the Parent/Child Notification Server, and from the Parent/Child Notification Server to the Child Notification Server:

  • Altiris Client Task Agent
  • Altiris Power Management Agent
  • Altiris Script Task Agent
  • Altiris Service Control Task Agent

Change their install policies to use the All Package Servers Collection, as the Parent and Parent/Child Notification Servers will only manage Notification Servers. Child Notification Servers can either use their default collections or one that is more suitable for the environment that it manages.

When configuring the Task Server policy on the Parent and Parent/Child Notification Servers, also use the All Package Servers Collection, and then just add either the Parent or Parent/Child Notification Server as the Task server that manages that Collection. Different Collections will obviously be used on the Child Notification Servers.


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33355


Article URL http://www.symantec.com/docs/HOWTO6897


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