Error: "Unable to launch AMS client uninstall" when upgrading Norton AntiVirus Corporate Edition 7.5 or 7.6 to Symantec AntiVirus Corporate Edition 8.x client

Article:TECH100325  |  Created: 2003-01-01  |  Updated: 2004-01-26  |  Article URL http://www.symantec.com/docs/TECH100325
Article Type
Technical Solution


Environment

Issue



You are upgrading a Norton AntiVirus Corporate Edition 7.5 or 7.6 client to Symantec AntiVirus Corporate Edition 8.x on Windows 2000 or Windows XP. When you start the installation, the following message appears in the Installshield Wizard: "Unable to launch AMS Client Uninstall."


Cause



The cause is the existence of the registry value HKLM\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\AMSClientInstalled =1 and the absence of the folder the AMS client resides in as specified by the HKLM\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\AMSInstallPath value (C:\Program Files\NavNT\AMS2). This folder is created by the installation of a unmanaged client. The following is an excerpt from an installation log that illustrates when this happens. This log file can be found in the users' temp folder, and will be named setup-.log; the timestamp will bear the date of the installation attempt. NAV_MSG: Loading C:\DOCUME~1\CMARTI~1\LOCALS~1\Temp\1\~SMI31CE\SYMANT~1.MSI\Support\NAVCUST2.DLL Action 9:14:44: PreMoveMigration_RB. Action 9:14:44: PreMoveMigration. Searching for previous installations NAV_MSG: PreMoveMigration() Action 9:14:44: PreMoveProcessing_RB. Action 9:14:44: PreMoveProcessing. Searching for Symantec AntiVirus services NAV_MSG: PreMoveProcessing() NAV_MSG: Remove old CBA directory files... NAV_MSG: Remove old SSC directory files... NAV_MSG: Copy uncompressed files... NAV_MSG: RBFileCopy: Copying C:\DOCUME~1\CMARTI~1\LOCALS~1\Temp\1\~SMI31CE\SYMANT~1.MSI\INSTOPTS.INI to C:\DOCUME~1\CMARTI~1\LOCALS~1\Temp\1\{0EFC6~1 Action 9:14:44: UnInstallAMS_RB. Action 9:14:44: UnInstallAMS. UnInstalling Alert Management System NAV_MSG: UnInstallAMS() NAV_MSG: UseNavCust2() NAV_MSG: IsUninstall(): Reading Property: REMOVE = NAV_MSG: Loading C:\DOCUME~1\CMARTI~1\LOCALS~1\Temp\1\~SMI31CE\SYMANT~1.MSI\Support\NAVCUST2.DLL NAV_MSG: UnInstallAMS:(Migration)Removing the old AMS2 directory at C:\Program Files\Navnt\AMS2 Action 9:33:48: ISUnSelfRegisterFiles. At 9:14 the uninstallation of AMS begins. Notice the last entry before 9:33. It indicates that the uninstall is going to attempt to remove the C:\Program Files\Navnt\AMS2 folder. It is at this point that the error is generated because the C:\Program Files\Navnt\AMS2 folder did not exist. The error message sat on the screen until 9:33 until user clicked the OK button and the install proceeded.

Solution



Clicking OK on the error message box allows the client to install successfully.

To prevent the message from appearing in the future
Follow these instructions on clients that have not yet been upgraded in order to prevent the message from appearing during the upgrade.

WARNING: We strongly recommend that you back up the system registry before making any changes. Incorrect changes to the registry could result in permanent data loss or corrupted files. Modify only the keys specified. Read the document How to back up the Windows registry before proceeding.
  1. Start the registry editor.
  2. Navigate to the following key:

    HKEY_LOCAL_MACHINE\SOFTWARE\INTEL\LANDesk\VirusProtect6\CurrentVersion
  3. In the right pane, right-click AMSClientInstalled and then click Modify.
  4. Change the value data entry from decimal 1 to decimal 0, and then click OK.
  5. Close the registry editor.







Legacy ID



2003050111245448


Article URL http://www.symantec.com/docs/TECH100325


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