The Home, Monitors and Reports tabs in the Symantec Endpoint Protection Management console fail to load while attempting to connect to the database.

Article:TECH102692  |  Created: 2007-01-18  |  Updated: 2010-01-17  |  Article URL http://www.symantec.com/docs/TECH102692
Article Type
Technical Solution


Issue



When trying to view the Home, Monitors and Reports tabs from within the Symantec Endpoint Protection management console the pages never load. The pages stay in a "Loading" state while viewing one of the three tabs.

Symptoms
SQL 2005 was installed to a named instance.

IIS logs indicate no errors.

The following Event ID is generated by the Web Publishing service a few minutes after attempting to load the tabs:

Event Type: Error
Event Source: W3SVC-WP
Event Category: None
Event ID: 2216
Date: 10/18/2007
Time: 11:43:44 AM
User: NA
Computer: (Computer name)
Description:
The script started from the URL '/Reporting/dashboard/homepage.php' with parameters ' ' has not responded within the configured timeout period. The HTTP server is terminating the script.

For more information, see Help and Support Center at URL: http://support.microsoft.com/


Cause



When creating a new database during the Symantec Endpoint Protection Manager installation, the named instance was not included when identifying the Database Server. When the 'SymantecEndpointSecurityDSN' configuration routine occurs, the SQL Server field will populate depending on what was placed in the Database Server field during installation.

Solution



For 32-bit systems
To resolve this, open the 'SymantecEndpointSecurityDSN' and configure the ODBC connection properly:
  1. Navigate to the Data Sources (ODBC) tool by clicking on Start> Programs> Administrative Tools> Data Sources (ODBC)
  2. Click on the System DSN tab.
  3. With the "SymantecEndpointSecurityDSN" highlighted click on the Configure... option.
  4. Under 'Which SQL Server do you want to connect to?' you must specify the Server name\SQL Instance.
  5. Click on the drop down menu and choose the Server name (SQL instance should be available to select.). Select the proper instance and click Finish.
  6. On the ODBC tab, test the connection by pressing Test Connection.
  7. Log in to the console and test the Home, Monitors and Reporting tabs.
If you are using the embedded Sybase Database (instead of a SQL Server), please do the following:
  1. Navigate to the Data Sources (ODBC) tool by clicking on Start> Programs> Administrative Tools> Data Sources (ODBC)
  2. Click on the System DSN tab.
  3. With the "SymantecEndpointSecurityDSN" highlighted click on the Configure... option.
  4. Under the "Database" tab, type in the Server name (computer name) of your Manager, where the database resides. If computer name does not work, try the IP number or fully qualified domain name.
  5. On the ODBC tab, test the connection by pressing Test Connection.
  6. Log out (if the Manager is opened) and log back in to the console to test the Home, Monitors and Reporting tabs.


For 64-bit systems
The ODBC information for 64 bit systems will not appear in the Data Sources (ODBC) applet, because SEPM creates a 32-bit DSN. To edit these settings, you must make the appropriate modifications directly in the registry:
  1. In Regedit, navigate to HKLM\Software\WOW6432Node\ODBC\ODBC.INI\SymantecEndpointSecurityDSN\
  2. Enter the appropriate data in the value Server, as indicated in the steps above.

NOTE: to modify the 32bit data sources you can run the file odbcad32.exe from the c:\windows\syswow64 folder.



References
The Symantec Endpoint Protection product installation_guide.pdf (Table 4-2, page 76) contains a description of what to place in the Database Server field.


For additional troubleshooting tips when experiencing communications issues with the Symantec Endpoint Protection Management Console please see Symantec Endpoint Protection Manager 11.x communication troubleshooting.

This document is available in the following languages:






Legacy ID



2007101811190348


Article URL http://www.symantec.com/docs/TECH102692


Terms of use for this information are found in Legal Notices