Installation of the Symantec Endpoint Protection Manager on a 64-Bit OS Does not Display the ODBC Connection

Article:TECH102763  |  Created: 2007-01-30  |  Updated: 2012-05-22  |  Article URL http://www.symantec.com/docs/TECH102763
Article Type
Technical Solution


Issue



After installing the Symantec Endpoint Protection Manager (SEPM), the Data Source Name (DSN) entry is not listed in the Open Database Connectivity (ODBC) control panel.



Error



Symptoms

The SEPM is installed to a 64-bit Windows OS.

  • The install of the SEPM produces no errors.
  • The "SymantecendpointDSN" is not listed in the systemDSN tab in the ODBC connection.


 


Cause



The SEPM installation registers creates a 32-bit ODBC DSN which is stored in the "WOW6432Node" registry hive. This hive is not polled by the ODBC control panel in Windows x64 versions.


Solution



This is normal behavior and does not prevent the Management Console from functioning if the ODBC information in the registry is correct.

To view the 32bit ODBC connectors, run odbcad32.exe from the Windows\SYSWOW64 folder.


References
http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=2219744&SiteID=1



 




Legacy ID



2007103007020148


Article URL http://www.symantec.com/docs/TECH102763


Terms of use for this information are found in Legal Notices