File System Auto-Protect is malfunctioning
| Article:TECH102962 | | | Created: 2007-01-21 | | | Updated: 2011-08-19 | | | Article URL http://www.symantec.com/docs/TECH102962 |
Problem
The Symantec Endpoint Protection client shows the following warning: "File System Auto-Protect is not functioning correctly. Your protection definitions may be damaged or your product installation may be corrupt"
Cause
There are several possible causes for this issue:
1. After migration from Symantec Antivirus (SAV), the computer was not restarted.
2. Corrupted virus definitions.
3. Incorrect DCOM permissions prior to installation.
4. Services not started or set to disabled.
Solution
Solution 1: After migration from SAV, the computer was not restarted
- Restart the computer to finish the uninstall of SAV.
Solution 2: Corrupted Virus Definitions
- Follow the instructions in this article to run the Intelligent Updater on the client machine to update the definitions:
How to update definitions for Symantec Endpoint Protection using the Intelligent Updater
Solution 3: Incorrect DCOM Permissions prior to installation
- Uninstall SEP
- Change DCOM permissions
- Re-install SEP
To change the Default Impersonation Level using Dcomcnfg.exe
- On the Windows taskbar, click Start > Run.
- Type the following: dcomcnfg.exe
- Click OK.
- Perform one of the following:
- In Windows 2003/XP, expand Component Services, and then expand Computers. Right-click My Computer, and click Properties. On the Default Properties tab, on the Default Impersonation Level menu, click Identify.
- In Windows 2000, on the Default Properties tab, on the Default Impersonation Level menu, click Identify.
- Click OK.
Solution 4: Services not started or set to disabled
Start and set Symantec services to 'Automatic' startup type
- Open the Windows Services Console
- Click START > Run
- Type and execute command 'Services.msc'
- Make sure that the following services are started and set to 'Automatic'
- Symantec Endpoint Protection
- Symantec Event Manager
- Symantec Management Client
- Symantec Settings Manager
If the above services are not set to 'Automatic' follow the below steps for each.
- Select and right click 'Symantec *Service Name*'
- Select 'Properties'
- Change 'Startup Type' to 'Automatic'
- Click 'Apply'
If the above services are set to automatic, but are not started, follow the below steps.
- Select and right click 'Symantec *Service Name*'
- Click 'Start' to start the service.
- The Symantec Services should now be Started and set to 'Automatic' startup type.
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Legacy ID
2007112113262148
Article URL http://www.symantec.com/docs/TECH102962
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