Mac OS X Server runs out of disk space after installing Symantec Antivirus (SAV) 10 for Mac

Article:TECH103426  |  Created: 2007-01-05  |  Updated: 2008-01-10  |  Article URL http://www.symantec.com/docs/TECH103426
Article Type
Technical Solution


Environment

Issue



After the installation of Symantec Antivirus for Macintosh 10.x, the OS X Server runs out of disk space.

Symptoms
The server runs out of disk space, causing "disk full" errors (such as "No space left on device (28)" PHP errors when logging into the SACM) or other problems.



Cause



The transaction logs are not being removed from the disk due to a setting in MySQL.

Solution



The MySQL variable expire_log_days has a value of 0; therefore, logs don't expire and don't get deleted. The log files are stored in /var/mysql/; the files are symupd-bin.xxxxxx, where xxxxxx is a number. The binary log is used for replication of databases, so in most cases it's not really needed.

To change the variable so that logs expire (and get deleted) after one day:
    1. Log in to the mysql database with the mysql command line client via Terminal:
      mysql -u root -p
    2. Check the value of the expire_logs_days variable:
      show variables like 'expire%';
    3. If the value of expire_logs_days is 0, you will want to change it to 1:
      set global expire_logs_days=1;
    4. To verify the variable has been changed, repeat the command given in step 2.

    The log files already present may need to be manually deleted, but future logs should automatically be purged after one day.





Legacy ID



2007556616723598


Article URL http://www.symantec.com/docs/TECH103426


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