Symantec Endpoint Protection Manager installation rolls back.

Article:TECH104408  |  Created: 2008-01-17  |  Updated: 2014-04-11  |  Article URL http://www.symantec.com/docs/TECH104408
Article Type
Technical Solution


Issue



Installation of the Symantec Endpoint Protection Manager (SEPM) fails.  Attempting installing to another drive or partition does not resolve the issue.  Using the Cleanwipe tool and then attempting the reinstall is likewise unsuccessful.

 


Error



At the end of the Symantec Endpoint Protection Manager installation a rollback is performed.

  • Install of the Symantec Endpoint Protection Manager fails with a return code 3 in SEPM_INST.log
  • Install of the Symantec Endpoint Protection Manager fails with a error 1603 in SEPM_INST.log
  • Install of the Symantec Endpoint Protection Manager fails at the point of configuring IIS

An example from the SEPM_INST.log:

    MSI (s) (50:EC) [17:46:49:796]: MainEngineThread is returning 1603
    MSI (s) (50:C0) [17:46:49:796]: Destroying RemoteAPI object.
    MSI (s) (50:E0) [17:46:49:796]: Custom Action Manager thread ending.
    MSI (c) (50:D8) [17:46:49:843]: Back from server. Return value: 1603
    MSI (c) (50:D8) [17:46:49:843]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied. Counter after decrement: -1
    MSI (c) (50:D8) [17:46:49:843]: PROPERTY CHANGE: Deleting SECONDSEQUENCE property. Its current value is '1'.
    Koniec działania 17:46:49: ExecuteAction. Return value 3. ( End of action - return code 3 )
    MSI (c) (50:D8) [17:46:49:843]: Doing action: SetupCompleteError
    Działanie 17:46:49: SetupCompleteError.
    Początek działania 17:46:49: SetupCompleteError.
    Działanie 17:46:49: SetupCompleteError. Dialog created
    Koniec działania 17:46:55: SetupCompleteError. Return value 2. ( End of action - return code 2 )
    Koniec działania 17:46:55: INSTALL. Return value 3. ( End of action - return code 3 )
    MSI (c) (50:D8) [17:46:56:046]: Destroying RemoteAPI object.
    MSI (c) (50:24) [17:46:56:062]: Custom Action Manager thread ending.

Environment



Symantec Endpoint Protection 11.x or 12.1.x


Cause



Running the SymHelp tool to check for potential installation issues can often reveal the cause of the failure.

SEPM installation failures have been known to stem from a corrupted Windows Script Environment or from conflicts with previous installations of LiveUpdate.  However, these are not the only causes.  


Solution



Reinstall Windows Script Environment
 




Legacy ID



2008031709003448


Article URL http://www.symantec.com/docs/TECH104408


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