What versions of Java are compatible with Symantec AntiVirus for Linux?

Article:TECH104703  |  Created: 2008-01-14  |  Updated: 2013-10-18  |  Article URL http://www.symantec.com/docs/TECH104703
Article Type
Technical Solution


Environment

Issue



What versions of Java are compatible with SAVFL (Symantec AntiVirus for Linux)?


Symptoms
Installation may stop responding at savjlu. If the installation does complete, LiveUpdate fails with error "LiveUpdate did not complete normally"

 


Cause



SAVFL is compatible only with Sun Java and requires Unlimited Strength Java(TM) Cryptography Extension (JCE) policy files.


Solution



Ensure Sun JDK or JRE 1.4 or higher (1.4, 1.5 , 1.6 and 1.7) is installed and configured as the default java.

If Java is reconfigured after SAV for Linux has already been installed, the JAVA_HOME value in /etc/Symantec.conf must be updated.
This can be done manually, or automatically by running /opt/Symantec/symantec_antivirus/update_java_home.sh
A system restart may be necessary.

Ensure also that Unlimited Strength Java(TM) Cryptography Extension (JCE) policy files are used rather than limited jar policy files.

For the latest files
Download the 'Java Cryptography Extension (JCE) Unlimited Strength Jurisdiction Policy Files' from http://www.oracle.com/technetwork/java/javase/downloads/index.html and follow the instructions.

For older versions
Follow links at page above for 'previous releases', 'archive', etc. and look for the same files.


Supplemental Materials

Value1248892


Legacy ID



2008041409001548


Article URL http://www.symantec.com/docs/TECH104703


Terms of use for this information are found in Legal Notices