Error: "Error initializing modem" when launching a pcAnywhere host or remote modem connection

Article:TECH106508  |  Created: 1996-01-25  |  Updated: 2006-01-25  |  Article URL http://www.symantec.com/docs/TECH106508
Article Type
Technical Solution

Environment

Issue



When you launch a pcAnywhere host or remote modem connection, you see the following error message: "Error initializing modem." You may also see a TAPI modem alert.


Cause



This may be caused by corruption within that host or remote icon. By unchecking and rechecking the modem, you are rewriting that connection item.

Solution



Please test after completing each section to see if the problem is resolved. If the problem persists, continue to the next section for another resolution.

To reset the modem:
An earlier pcAnywhere session or another application may not have reset the modem or serial port correctly. The simplest solution is to reset the modem.

To reset an internal modem:
  1. Shut down Windows and power off the computer.
  2. Wait ten seconds.
  3. Restart the computer.
  4. Re-launch the pcAnywhere host.

To reset an external modem:
  1. Turn off the modem.
  2. Shut down and restart Windows.
  3. Turn the modem on.
  4. Re-launch the pcAnywhere host.

To test the modem in HyperTerminal:
  1. Exit all open applications.
  2. Click Start, point to Programs, point to Accessories, point to HyperTerminal, and then click HyperTerminal.
    NOTE:Under Windows 2000/XP, click Start, point to Programs, point to Accessories, point to Communications, and then click HyperTerminal.
  3. Enter a name for the HyperTerminal connection, and then click OK.
  4. Enter a single digit in the Phone number field.
  5. Select the modem from the "Connect using" drop-down menu, and then click Cancel.
  6. In the blank HyperTerminal window, type atz and then press Enter. The modem should respond with OK. If the modem does not respond or does not respond with OK, it may not be configured properly in Windows. Please contact the hardware manufacturer for further assistance.
  7. Close the HyperTerminal window. There is no need to save the changes.

To test the modem using Phone Dialer:
Refer to the document How to test a modem using Phone Dialer.

To refresh the Connection Device information:
  1. In the pcAnywhere Manager, right-click the Modem connection item that you are having troubles with, and then click Properties.
  2. Select a different device from the Device list, and then click OK.
  3. Close and restart pcAnywhere.
  4. Right-click the connection item, and then click Properties.
  5. Reselect Modem from the Device list, uncheck the previous device, and then click OK.
  6. Close and restart pcAnywhere.
  7. Retest the connection.

To create a new connection item:
  1. In the pcAnywhere Manager, click either Be a host PC, or Remote Control, depending on whether the connection device that you are having problems with is a host or a remote.
  2. Click File, and then click New.
  3. From the Device List, select the modem.
  4. Configure the rest of the connection item with the information from the problem item.
  5. Click OK when finished.
  6. Test the connection with the new connection item.

Uninstall and reinstall the COM port:
In some cases, if the COM port is incorrectly configured, uninstalling and reinstalling it will resolve the problem. To do this, delete the COM port from the Device Manager, then restart Windows. Windows should automatically detect and reinstall the COM port. If not, you can add it by using the Add New Hardware wizard.

Check for updated modem driver:
If all else fails, check with your modem manufacturer to see if there is an updated driver for your modem.





Legacy ID



19961125153023


Article URL http://www.symantec.com/docs/TECH106508


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