Issue with Intel network interface cards while using Symantec Ghost

Article:TECH108189  |  Created: 2002-01-04  |  Updated: 2011-11-07  |  Article URL http://www.symantec.com/docs/TECH108189
Article Type
Technical Solution

Product(s)

Problem



How to use an Intel Pro 100, Intel Pro 1000 or Intel 8256x NIC ( Network Interface Card ).
You may see error messages related to the network card, GhostCast is greyed out or your console tasks fail at the To Virtual Partition step.

Symptoms
Symptoms include but are not limited to:

  • Error messages about the inability of the NIC or 'Packet Driver' not able to 'bind.'
  • Error messages about the inability to obtain an IP by DHCP.
  • GhostCast is greyed out.
  • Console tasks failing with the error ' to virtual partition - failed .'


 


Cause



Some of the NIC drivers that come with Symantec Ghost and older are out of date. Since the hardware has changed since the drivers were licensed, it is sometimes necessary to download new drivers.


Solution



There is a newer versions of the drivers for the Intel NIC's. To obtain the driver, follow these steps:

Symantec Ghost Solution Suite 2.5:

If you are using DOS, please see the instructions below in the section, "Symantec Ghost Solution Suite 2.0 and earlier (and 2.5 using DOS)"

If you are using WinPE, you will need the Vista Ulitimate 32 bit driver. It can be found at either of the sites below. Both of these drivers have been successfully used some Intel 8256x, Intel Pro1000 and Intel Pro 100 NICs.


Where to get and how to add the latest Intel driver for use with WinPE:

  1. Once you download a driver, use these instructions to unpack the drivers: http://service1.symantec.com/support/on-technology.nsf/docid/2008081107094760
  2. Then add the drivers with these instructions: http://service1.symantec.com/support/on-technology.nsf/docid/2008050916132860
    • (The driver you need is in the \PRO1000\Win32\NDIS61 folder)
  3. Once you have added the driver, check the box so WinPE uses that driver. Also, make sure you uncheck all the other Intel drivers.


In some cases you have to add a more specific file from the set of files included in the package from Intel. You will need to remove all the unneeded drivers from the files they supply and only use the one for the specified device:

  1. Look at the error in the task log or that the /eval switch reports and get the device ID (usually something like 10de)
  2. Open the folder where you unpacked the drivers and search through each .inf file until you find the one that has the device ID that matches the device named in the error. (You can do a “Find” for the device number)
  3. Once you have determined which .inf is specific to the device being used, you can create a temp folder and put all other .inf files in the temp folder and get them out of the Pro1000\Win32\NDIS61 folder so Ghost is forced to select the e1k6032.inf file.
  4. You will get an error about the other drivers…just click OK


Or you can use drvload.exe to force Ghost to use the correct driver: http://service1.symantec.com/support/on-technology.nsf/docid/2008102007571160


Symantec Ghost Solution Suite 2.0 and earlier (and 2.5 using DOS):
 

  1. Visit the web site: http://downloadcenter.intel.com/Product_Search.aspx?Prod_nm=PRODOS.EXE&page_nbr=1&lang=eng.
  2. Click on " PRODOS.exe...". Select the newest DOS NDIS2 NIC driver listed there.
  3. Accept the licensing agreement if you do accept it.
  4. Click on " Network Adaptor Drivers for MS-DOS. "
  5. Save the file to the Desktop of your computer.
  6. Double click on the file that was downloaded, call PRODOS.EXE. You will be asked to specify to where you want the driver files unzipped. This will NOT affect your Windows NIC driver/s.
  7. If you are using an Intel Pro1000 or 8256x NIC, use the DOS driver for the Intel Pro 1000 as described below.


Next, you will need to add the NIC driver into the Ghost Boot Disk Wizard. For instructions, check the link: ' Adding or modifying NIC templates in the Ghost Boot Wizard ' at http://service1.symantec.com/support/on-technology.nsf/docid/2000011211551725?Open&seg=w You must also specify the ' Driver Name ' when adding the NIC into Ghost. This field shows up when you are browsing for the .DOS file. The driver name should match the file name as follows:

For the Intel Pro 100 NIC, the Driver Name should be e100$
For the Intel Pro 1000 NIC, the Driver Name should be e1000$
For the Intel 82566 NIC, the Driver Name should be e1000$
For the Intel 82567 NIC, use the Pro 1000 NIC driver and set the Drive Name to e1000$
For the Intel 82562 NIC, use the Pro 100 NIC driver and set the Driver Name to e100$

After you have added the NIC driver to the list of NIC Templates, you must tell Symantec Ghost to use it. Refer to the last section of the document ' Adding or modifying NIC templates in the Ghost Boot Wizard ' at http://service1.symantec.com/support/on-technology.nsf/docid/2000011211551725?Open&seg=w'.



 



Legacy ID



2002100414292225


Article URL http://www.symantec.com/docs/TECH108189


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