How to reinstall the Ghost Console or move it to a new computer

Article:TECH110341  |  Created: 2008-01-13  |  Updated: 2013-10-30  |  Article URL http://www.symantec.com/docs/TECH110341
Article Type
Technical Solution


Environment

Issue



What considerations should be taken into account when reinstalling the Console or moving it to a different computer?

It is recommended practice to back up your Console database before upgrading to a newer version. When the newer version of Ghost is installed, permanent changes to the database are made, so you cannot go back to the original installation. By backing up your data before you upgrade, you will have a recourse in the event of a failed update.


Cause



The Ghost database contains information specifically used in the Ghost Console. This includes machine names, task definitions, configuration sets, Sysprep configurations, etc. Not all the information used by the Ghost Console is in the database.


Solution



NOTE: For a short summary on moving the Ghost Solution Suite 2.x Console, check the document 'How to move the Symantec Ghost Console 2.x to a new computer, or retain console settings during reinstallation.' at http://www.symantec.com/docs/TECH110251.

Upgrading Ghost

    • If you plan to upgrade from an earlier version of Ghost, and you have been using the Ghost Console, back up your Ghost database first. See below for instructions. If you have been using the Console, then upgrade version by version. For example, if you have Ghost Solution Suite 1.0, you would want to appy version 1.1 over the top of version 1.0. Then, appy version 2.0 and finally apply version 2.5. If you need the media for different versions of Ghost, contact Symantec Technical Support.

 

Multiple installations of the Console

    • Each client computer can only be managed by one Console at a time. You may install the Console on more than one computer. It will be up to you to keep a tally of the total number of client licenses you have used. No one individual Console will show this information. It must be computed by adding up the number of licenses used by each Console as well as the other uses of one of the Ghost executables such as with the GhostCast Server. For information about licensing, check the document 'Introduction to Symantec Ghost licensing' available at http://www.symantec.com/docs/TECH107649.


System Requirements

    • Check the system requirements for Ghost as documented in the article 'System Requirements/Installation Requirements for Ghost Solution Suite 2.0 and 2.5.' located at http://www.symantec.com/docs/TECH110217.


System Images

    • Images are not automatically included when backing up the Console. Existing images should be stored to a safe location.
      NOTE: We recommend that you put only one image per folder so that they are easier to manage.


Backup Regimes

    • Backup regimes are not copied over when you back up your Console. If you are moving the Console to a different machine, the regimes must be re-added by hand in the new Console. The image files for the backup regimes can be used to restore a computer, but only by hand from the computer running the old installation of the Console.


AI Packages

    • AI Packages are not included in a typical backup of the Ghost database. When you have moved the Console to a different computer, the AI Package definitions will be listed as present, but, you must copy the .EXE part of the package from the old installation of the Console to the new computer. When you go to deploy the AI package on the new installation, you will need to tell Ghost where the package is located. This will reassociate the AI Package definition with the .EXE file that will be used when the package is deployed.


Drivers that were added to Ghost

    • Drivers that were added to Ghost by hand are not included when you back up your Console with the backup tool. ( See below for the backup tools. ) You can, however move the drivers to a new installation of the Console by hand. NOTE: Drivers added to Ghost will be retained when Ghost is uninstalled. Drivers that were not manually added to Ghost will be deleted if Ghost is uninstalled.
    • DOS NIC drivers are located in the folder \Documents and Settings\All Users\Application Data\Symantec\Ghost \Template. You can locate a NIC driver template that you have created yourself and copy it to the same Template folder on the new installation of the Console. To determine the folder name of a DOS NIC driver that has beed added, open the Ghost Boot Wizard, click on PC-DOS > Next > Network Boot Package. Make sure that the checkbox ' Show All Drivers ' is unchecked. Any drivers other than ' Universal Packet Driver 2.0 ' and ' Universal Packet Driver v2.0 [irqcfg] ' are ones that have been added to Ghost.
    • Windows PE drivers are not backed up when using the backup tool. Again, you can move them to the new installation of the Console by hand. The PE driver are located in folders at \Documents and Settings\All Users\Application Data\Symantec\Ghost \Template\common. Copy folders that represent the Windows PE databases that you want to preserve. At the new installation of the Console, paste the copied folder in the same location on the new computer.

 

Scheduled Tasks

    • The tasks that you have build previously will be carried over, but the scheduling must be reconfigured after restoring the Ghost database.

Sysprep definitions

    • Sysprep definitions are not carried over. After restoring the database, the names of the Sysprep definitions will be restored, but the executables and unattend files are not included. You could copy the unattend files and executables from the old Console by hand. They are listed at: C:\Documents and Settings\All Users\Application Data \Symantec\Ghost\Sysprep under Config and Executables respectively. For the unattend files, the folder naming convention makes it difficult to determine which unattend file is which. It may be easier to start over on the unattend files. If it is important that you obtain the existing unattend files, follow the procedure below.
    • To obtain the old unattend files for Sysprep definitions, modify the unattend file to contain some text that you can then search for. Do the following:
      1. Open the Console.
      2. Select File > New > Image Create Task.
      3. Click on the Sysprep tab.
      4. Select ' Run Microsoft Sysprep... '.
      5. Browse for the Sysprep configuration you want to extract.
      6. Click OK, Edit, Modify.
      7. Change the Computer Name field to contain a ' key word ' such as ' THIS UNATTEND '. This will have to be reset after you have extracted the unattend file, but for now, just use some unique text.
      8. Click on OK and OK. This saves your changes to the unattend file.
      9. Open the folder C:\Documents and Settings\All Users\Application Data \Symantec\Ghost\Sysprep\Config
      10. Click on Search. ( This is the Windows ' Search ' feature. )
      11. Where the Windows browser asks for ' A word or phrase in the file ', specify the same text, such as ' THIS UNATTEND '.
      12. Click on Search. The unattend file that shows up is the one you were looking for.

Restoring to the same version of Ghost

    • A backup of the Ghost database can only be restored to an installation of the same version. If you plan to upgrade, you must first install the old version of Ghost, import the old database and then upgrade over the top. You can restore to versions of Ghost that are the same version but not the same exact update. For example, if you have Ghost Solution Suite version 2.0.2, you can restore from versions 2.0.0 and 2.0.1, but not from Ghost Solution Suite 1.1.


Console Service Account

    • The Console Service Account will not be modified. As long as you are not moving the Console to a different domain, the old Service Account should work, as long as you add it to the supported domains list in the new Console. If you are moving to a different domain, you will need to add a new Service Account.
      For either scenario, check the document 'Explanation of the Ghost service account' at http://www.symantec.com/docs/TECH107390.


Stop services before making a backup

    • The Ghost database services should be stopped before you attempt a backup. ( The backup tool is described in the next section. )
    • To stop the services, run the command: C:\Program Filse\Symantec\Ghost\ngserver.exe -stop
    • To start them run the command: C:\Program Files\Symantec\Ghost\ngserver.exe -install


Backup Scripts

  • If you have version 2.0.x of the Ghost Solution Suite , you can use the backup scripts to make and restore backups of the Ghost database (backupdb.wsf and restoredb.wsf). Check the document 'Ghost console database backup and restore tools' at http://www.symantec.com/docs/TECH109727.
    • If you have version 2.5 of the Ghost Solution Suite, you will find the GSS 2.5 versions of the above scripts in the Ghost console install folder. (C:\Program Files\Symantec\Ghost by default.)


To back up the database manually

    • For versions 2.x, the backup scripts should usually work. If not, check the document 'How to move the Symantec Ghost Solution Suite 2.x Console to a different computer or retain Console settings during a reinstall' at http://www.symantec.com/docs/TECH109618.
    • If you have a version of the Ghost Solution Suite older than 1.1, follow the instructions in the document: 'How to upgrade Ghost Solution Suite version 1.1 or earlier Ghost installation to Ghost Solution Suite 2.5 when a direct upgrade fails'How to move the Symantec Ghost Solution Suite 1.x Console to a different computer or retain Console settings during a reinstall' available at http://www.symantec.com/docs/TECH107776.


Moving the Console to a different computer

    • If you plan to upgrade, you should follow an upgrade path from your current version of Ghost step by step. For example, if you have Ghost Solution Suite 1.0, you would need to upgrade to 1.1, then to 2.0. then to 2.5, etc. If you need media for other versions of Ghost, contact Technical Support. Then, follow these steps:
      1. Install the old version of the Console on the new computer.
      2. Import the backup of the database using the scripts mentioned earlier.
      3. Upgrade step by step to get to the latest version.
    • If you do not plan to upgrade, then follow these steps:
      1. Install the Ghost Console on the new computer.
      2. Import the backup of the Console database using the scripts mentioned earlier.
    • Generate a new certificate file PUBKEY.CRT as follows:
      On the new computer, run NGSERVER.EXE -KEYGEN This will make a brand new PUBKEY.CRT file for the new installation of the Console.
      For details, see the document: 'How to regenerate the pubkey.crt file on the Ghost Console machine' available at http://www.symantec.com/docs/TECH110306.
    • Associate the Client computers with the new Console as follows:
      Copy the new PUBKEY.CRT file to the client computers.
      For details, see the document 'Uninstalling a Symantec Ghost™ Client or modifying it to work with a new Console' available at:http://www.symantec.com/docs/TECH107982.
      If you have a large number of computers, you may want to update the PUBKEY.CRT files with a script. Check the document 'How to distribute the "pubkey.crt" file to multiple client computers' available at http://www.symantec.com/docs/TECH110222.
       
    • If you upgraded, the Console Clients will be out of date. The icons for client computers will show red ( ! ) marks in the various machine groups. The Client agents will be updated automatically the first time you run a task on a client computer. If you want to update the client computers all together, you could build and run a Clone task that includes just the ' Configuration Refresh ' feature for a machine group.


Restoring the database

    • The database can only be restored to the same version of Ghost that was backed up. If you have upgraded, you must uninstall the newer version or versions and install the version that was running when the database was originally backed up. Then, you must upgrade step by step as described earlier in this document.
    • If you used the backup tool described earlier, you can restore the database with another one of the scripts.
    • If you backed up your database by hand, restore it using one of the following documents:
      • For version 2.x, check the document 'How to move the Symantec Ghost Solution Suite 2.x Console to a different computer or retain Console settings during a reinstall' at http://www.symantec.com/docs/TECH109618.
      • For versions older than 1.1, follow the instructions in the document: 'How to move the Symantec Ghost Solution Suite 1.x Console to a different computer or retain Console settings during a reinstall' available at http://www.symantec.com/docs/TECH107776


Run LiveUpdate

    • Depending on the version of Ghost, there may be one or more LiveUpdates that should be applied. If you have difficulties when applying the updates, contact Symantec Technical Support.
      • Run LiveUpdate from the Console under the Help menu in the Ghost Console until it reports that all Symantec product have been updated to the current version. To check to see if you have all theupdates, open the Ghost Explorer and click on Help > About. If you have version 11.5.0.2266, you have the latest version. Otherwise, run LiveUpdate again.
      • For version 11.0 of Ghost , there are two updates. Run LiveUpdate from under the Help menu on the Ghost Console. Run it twice to download the updates. The updates for version 11.0 of Ghost are full install packages.
    • Information about the updates can be obtained from the software change notices linked below:

References
Some automatic backups are made by Ghost. If you have questions, contact Symantec Technical Support.

Technical Information
Console Clients that are disconnected from the Console for an extended period of time may try to associate with a different Console. If this happens, you may have to reassociated the Clients. Check the document: Uninstalling a Symantec Ghost™ Client or modifying it to work with a new Console' available at: http://www.symantec.com/docs/TECH107982.

  • With version 2.5 and before, there is a known issue relating to the icon in the system tray on client computers. The client computer will show that it is being managed by the server that it connected to initially. Reassociating the client with a new server does NOT cause the server name to be updated. It will always show the name of the original server.


Legacy ID



2008101316440560


Article URL http://www.symantec.com/docs/TECH110341


Terms of use for this information are found in Legal Notices