Control Compliance Suite (CCS) Reporting and Analytics v8.50 install fails with "Fatal error during installation"

Article:TECH113392  |  Created: 2007-01-27  |  Updated: 2010-09-02  |  Article URL http://www.symantec.com/docs/TECH113392
Article Type
Technical Solution


Issue





Symptoms
CCS Reporting and Analytics v8.50 install does not complete.

    • The final dialog box displays an error message Fatal error during installation.



 


Cause



Microsoft Windows patch this security update addresses two vulnerabilities by modifying the way .NET Framework addresses buffer allocation. Either Microsoft Windows Server 2003 SP2 or Microsoft patch KB928365 are installed -OR- Microsoft .NET Framework v.2.0 or later is installed.


Solution



Install Quickfix CCS_ReportingAndAnalytics_v8.50_111_231788_QF.

      NOTE: Install the Quickfix on both the SMC Server and SMC Job Server computers. See step 1 below to download the quickfix files.

    Follow these steps to install the quickfix:
      WARNING: Perform each of the following steps in sequential order—DO NOT SKIP AHEAD.


    If you have already experienced this issue, please follow these steps:

    1. Download the quickfix files from ftp://ftp.symantec.com/public/english_us_canada/linked_files/CCS_ReportingAndAnalytics_v8.50_111_231788_QF.zip.
    2. Copy the batch file "SMC85-Uninstall.bat" into “ \Program Files\Symantec\Control Compliance Suite\Setup” folder.
    NOTE: \Program Files\Symantec\Control Compliance Suite\Setup is the default installation path.
    3. Run this batch file by double-clicking on it. (Note that a log file is in the current folder during this operation.)
    4. The “Symantec Control Compliance Suite” window appears showing the uninstall progress. Please wait until it completes.
    5. Delete the “SMC85-Uninstall.bat” file from “<INSTALLDIR>\Setup” folder.
    6. Using Microsoft SQL Server Enterprise Manager tool, backup then delete the following databases for the Symantec's Control Compliance Suite - Reporting and Analytics:

      a. ComplianceManager

      b. Dashboard

      c. EntitlementManager

      d. PolicyManager

      e. SMC

      NOTE: These are the default database names. When prompted in SQL, be sure to check the box "Delete backup and restore history."


    7. Install and run the Windows Installer Cleanup Utility to remove the Reporting & Analytics Add/Remove Programs (ARP) entry. The Windows Installer Cleanup Utility is available online at:

    8. If the services SMCServer and SMCJobServer still exist, run regedit to remove the following two registry keys:

        HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SMCServer

        and

        HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SMCJobServer.

    9. Remove the registry key HKEY_LOCAL_MACHINE\SOFTWARE\BindView and all SMC-related subkeys.
    10. Restart the computer.
    11. Copy the file BindView.Implementation.AAL.Shared.dll (v8.50.177.111) from the Quickfix install package to the folder “\Program Files\Symantec\Control Compliance Suite\SMC Server”.
    12. Run the Control Compliance Suite v8.50 Reporting & Analytics setup now.

      If you have not already experienced this issue but SP2 or the patch “KB928365” from Microsoft is already installed, then follow these steps:

      1. Download the quickfix files from ftp://ftp.symantec.com/public/english_us_canada/linked_files/CCS_ReportingAndAnalytics_v8.50_111_231788_QF.zip.
      2. Run the Control Compliance Suite v8.50 setup.
      3. Accept the license agreement, then click Next.
      4. Select a path for “Product Install Path:” field to where you want to install the software.
          NOTE: The default installation directory is C:\Program Files\Symantec\Control Compliance Suite.
      5. Minimize the installation wizard, then manually create the directory that was selected in step 4.
          Create a sub-folder named “SMC Server” in the directory that was selected in step 4.
      6. Copy the file BindView.Implementation.AAL.Shared.dll (v8.50.177.111) from the Quickfix package into the newly created “SMC Server” folder.
      7. Click Next. The installation wizard will guide you through the install process.




     



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    2007092708485853


    Article URL http://www.symantec.com/docs/TECH113392


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