WiseUpdt.exe causing error "An error occurred while trying to locate the update to..."

Article:TECH11376  |  Created: 2006-01-03  |  Updated: 2007-05-30  |  Article URL http://www.symantec.com/docs/TECH11376
Article Type
Technical Solution


Problem



WiseUpdt.exe is causing error "An error occurred while trying to locate the update to..." 

Cause



WiseUpdate is Wise Solution's prepackaged update checking and downloading utility. This system is designed in such a way that it can connect to a standard Web server and check to see if there is a new version of your application is available for download, and if so prompt the user to download the most recent version.

This technology requires three parts in order to function properly:

  • WiseUpdate client .exe.
  • WiseUpdate .ini file placed on the Web Server.
  • The .exe or .msi that is to be downloaded and installed.

The WiseUpdate client is a generic WiseScript .exe created from the WiseUpdt.exe file that is included with Wise Installation Studio and Wise Package Studio. The WiseUpdate client starts by looking at a registry key that stores the name and version of your installed application. It also reads the path to an Internet host, which you set up in your application's original installation. The Internet host contains the WiseUpdate .ini file.

You place the WiseUpdate .ini file on an FTP server by running the Distribution Wizard and choosing FTP server. The .ini file contains the current version of the installation, the file name of the updated installation .exe or .msi, and the size of the updated installation .exe/MSI. When the WiseUpdate client runs, it downloads the .ini file from the server and compares the version listed in the .ini file to the version of the currently-installed application. If the value on the server is newer than the version on the computer, the user is prompted to download and install the new version.

The WiseUpdate client supports automated checking of installation .exe files based on an elapsed number of days. You set up automated checking by adding the WiseUpdate client to the startup group and by defining the appropriate day intervals on the WiseUpdate page.


Solution



1. The file that is to be downloaded and installed, is it a newer version? 
2. Do you have a WiseUpdt.ini file, if so has it been updated?  The best way to create one of this is to use the distribute button in the Expert, and distribute the new exe to the web site. 


Legacy ID



17531


Article URL http://www.symantec.com/docs/TECH11376


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