Generate Report for this Standard task causes errors "Report Application Server failed" and "Class Not Registered" with Crystal Reports version 1.0.0

Article:TECH113883  |  Created: 2007-01-25  |  Updated: 2008-01-26  |  Article URL http://www.symantec.com/docs/TECH113883
Article Type
Technical Solution


Issue



Load Report Failed when the report task [Generate Report for this Standard] is selected for a given standard (not evaluation results)
Report Application Server failed when the report task [Generate Report for this Standard] is selected for a given standard (not evaluation results) InReportView.


Cause



Crystal Reports Hot Fix that addresses this problem was released by Crystal and then added to an SMC QF installset for release to SMC customers:

SecurityManagementCenter_v3.0_163_223202_QF

Solution



Download SecurityManagementCenter_v3.0_163_223202_QF and extract CRInstall.msi to a known directory.
  1. Copy CRInstall.msi from the quick fix package to the following folder: C:\Program Files\BindView\Security Management Center\Redist\
  2. Stop and start BindView SMC Server service.
  3. On the SMC Server and on each client machine, uninstall the Crystal Reports Viewer (version 1.0.0) using Windows Add/Remove Programs tool. Restart the computer if prompted.
  4. On the SMC Server and on each client machine, launch the SMC Console.
  5. The launcher process prompts you to install Crystal Reports. Click the Install now button.
  6. The SMC Console launches automatically after the Crystal Reports installation is complete.
  7. Make sure that the Crystal Reports Viewer (version 10.0.51380) program appears in Windows Add/Remove Programs tool.






Legacy ID



2007791709303998


Article URL http://www.symantec.com/docs/TECH113883


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