After renaming the Bindview Information Server (BVIS), the RMS Console fails to launch with the following message: "A failure occurred: Failed to connect to the Bindview Information Server. Its BVProcessManager Service may have encountered an error"

Article:TECH114256  |  Created: 2008-01-25  |  Updated: 2008-01-11  |  Article URL http://www.symantec.com/docs/TECH114256
Article Type
Technical Solution


Issue



After renaming the Bindview Information Server (BVIS), the RMS Console fails to launch with the following message: "A failure occurred: Failed to connect to the Bindview Information Server. Its BVProcessManager Service may have encountered an error"

Symptoms
The BVProcessManager service won't stay started.
  • There are errors in the application with the BVProcessManager listed as the Event Source (Event ID 62, and 25).



Cause



The machine name on the Bindview Information Server was changed. This will cause the SQL Security logins for the BV database used by the RMS Console to fail.

Solution



The following steps require SQL Enterprise Manager and will remove and re-create the SQL Security logins for the BV database, which is used by the RMS Console. Before beginning, close the RMS Console on the Bindview Information Server, as well as any remote consoles connected to that Information Server:
  1. Launch SQL Enterprise Manager on the Information Server. If this tool is not installed on the Information Server, you will need to add a new SQL Server Registration to the SQL instance running on the Information Server.
  2. Open Databases > BV.
  3. Select the Users Table and delete BV Console Users and BV Console Admins.
  4. Open Security > Logins and delete MACHINENAME\BV Console Users, MACHINENAME\BV Console Admins.
  5. Stop and start SQL to flush the changes from the database.
  6. From Security > Logins, add a new Login for "MACHINENAME\BV Console Admins" by using the browse feature in the 'SQL Server Login Properties - New Login dialog.
  7. While adding the new login, click on the General tab and select the BV database in the drop-down window.
  8. Click on the Database Access tab and check ‘Permit’ for the BV Database.
  9. Select the following under Permit in Database Role: 'public', 'db_datawriter', 'BV_Admins'
  10. From Security > Logins, add another new Login for "MACHINENAME\BV Console Users" by using the browse feature in the 'SQL Server Login Properties - New Login dialog.
  11. While adding the new login, click on the General tab and select the BV database in the drop-down window.
  12. Click on the Database Access tab and check ‘Permit’ for the BV Database.
  13. Select the following under Permit in Database Role: 'public', 'db_datareader', 'BV_Users'
  14. Close out of Enterprise Manager, and re-launch the RMS Data Collection Console.






Legacy ID



2008032514374753


Article URL http://www.symantec.com/docs/TECH114256


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