Query Engine (QE) or Enterprise Configuration Service(ECS) installation fails with error 'The file is being used by another process'.

Article:TECH115263  |  Created: 2008-01-30  |  Updated: 2011-12-13  |  Article URL http://www.symantec.com/docs/TECH115263
Article Type
Technical Solution


Issue



Query Engine (QE) or Enterprise Configuration Service(ECS) installation fails after configuration options have been specified in the install wizard and the installation process is launched. 


Error



InstallSupportService failed! The process cannot access the file because it is being used by another process.


Cause



There is a service on Windows 2003 called "Application Experience Lookup Service", which runs the _isdel.exe process. The _isdel.exe process is run from the (QE/ECS) InstallShield in the event that the installation needs to be backed out.

Application Experience Lookup Service does not exist on Windows 2008 x64 servers.

_isdel.exe is used by various InstallShield installation programs to enable the computer to delete temporary installation files from the Temp directory.


Solution



Follow the steps to resolve the issue

  1. Go to Start \ Run and type: Services.msc
  2. Disable the Application Experience Lookup Service before installing QE or ECS.
  3. Launch the Query Engine or Enterprise Configuration Service setup by running the appropriate Setup.exe file.
  4. Open Task Manager and go to the Processes tab.
  5. Make sure "Show processes from all users" is checked.
  6. Select the process _isdel.exe.
  7. End the process by clicking on End Process button
  8. Continue with the install. The installation wizard guides you through the remainder of the install process.


Legacy ID



2008123105504353


Article URL http://www.symantec.com/docs/TECH115263


Terms of use for this information are found in Legal Notices