Deployment Server causes issues with WMI depository

Article:TECH12077  |  Created: 2006-01-24  |  Updated: 2006-05-26  |  Article URL http://www.symantec.com/docs/TECH12077
Article Type
Technical Solution


Issue



Deployment Server causes issues with WMI depository. The problem in general seems to be that WMI on the deployment servers is broken. If I uninstall the Deployment server then our WMI works. Results  below:

Run the WMI properties through computer management, namely "Failed to connect to <local computer> because "<Null>: Unspecified error."" There's a Windows native utility called WBEMTEST.EXE. When I log on as a domain administrator and run it on these servers, I get an error such as this:

Number: 0x80041014
Facility: WMI
Description: Initialization failure

Additionally, if I run even the simplest WMI script, logged on locally as a domain admin on these servers, it fails.


Environment



Deployment Server 6.5.X
Altiris Package Server WMI Provider

Cause



At one point, Monitor Solution was installed, which provides the Altiris Package Server WMI Provider.

Solution



  1. Back up the server.
  2. Uninstall the Package Server WMI Provider using utility provided. Reboot.
  3. Remove the repository and re-register all the WMI DLLs. Reboot.
  4. Verify that the WMI is fixed.

Attachments

Remove_PkgSvrWMIProv_noMsiexec.zip (103 kBytes)

Legacy ID



18470


Article URL http://www.symantec.com/docs/TECH12077


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