Console throwing ActiveX Error when installing a CAB file: "The context help activex object fails to load."

Article:TECH12100  |  Created: 2005-09-12  |  Updated: 2005-09-12  |  Article URL http://www.symantec.com/docs/TECH12100
Article Type
Technical Solution


Issue



You are logged onto the NS machine which is Windows 2003 Server as the NS's AppId which is also a Local Administrator of this machine. NS 6.0.5287 with hotfix-18. Upon opening the Altiris Console you receive the following error: The context help activex object fails to load. "An error occurred constructing the tree from the XML provided by the server:Object required (-2146827864)"

Environment



Notification Server 6.0, Hotfix 18

Cause



Conflict between DLL's or possibly DLL's not installing properly.

Solution



The GUID that was showing up in the 'C:\Windows\Downloaded Program files' directory was the clue. We believe that the GUID should have been named "AeXNSConsoleContextHelp Class".

If you right click on the GUID, choose properties, and then click the Dependency tab, you can see the .dll's that are associated with this item. The fix was to delete the .dll's listed in the Dependency Tab that started with AeX. The following DLL's were removed from C:\Windows\system32 or C:\Windows:

 AEXNSCONSOLEUTILILTIESHF18.DLL
 AEXNSCONSOLEUTILITIES.DLL
 AEXSCHEDULERMGR.DLL
 AEXMENUCTRLLIB.DLL
 AEXTREECTRLLIB.DLL
 AEXNSPKGDLLIB.DLL
 AEXREG.TLB

After doing this, when opening the NS Console the CAB file will install successfully.


Legacy ID



1862


Article URL http://www.symantec.com/docs/TECH12100


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