NS Log error: Unable to generate policy XML for item: Inventory Plug-in...
| Article:TECH121961 | | | Created: 2010-01-21 | | | Updated: 2012-01-30 | | | Article URL http://www.symantec.com/docs/TECH121961 |
Problem
The Inventory Plug-in for Windows Install policy was enabled, but computers were not receiving or installing the install package.
The NS Logs contained many instances of the errors similar to:
Module: w3wp.exe Source: Altiris.NS.AgentManagement.PolicyRequest.LoadItemPolicy Description: Unable to generate policy XML for item: Inventory Plug-in for Windows Install (1d04c3ce-0957-462e-9ea3-9938600ebd7b). Reason: Did not get a row for Software Delivery Advertisement "Inventory Plug-in for Windows Install", Guid = Inventory Plug-in for Windows Install (1d04c3ce-0957-462e-9ea3-9938600ebd7b) from the SWD tables. ---> Altiris.NS.Exceptions.AeXException: Did not get a row for Software Delivery Advertisement "Inventory Plug-in for Windows Install", Guid = Inventory Plug-in for Windows Install (1d04c3ce-0957-462e-9ea3-9938600ebd7b) from the SWD tables.
Environment
Symantec Management Platform 7
Inventory Solution for Windows 7
Cause
The policy is supposed to reference the package: Inventory Plug-in for Windows Package. The package was supposed to be represented in the SWDPackage table, but it was not there. As a result the NS could not respond with the package the policy was referencing in the agent request.
Solution
To test if the identified cause exists run the following SQL query in a query analyzer program against the Symantec_CMDB database:
SELECT Name, PackageId
FROM SWDPackage
WHERE PackageId = '87AB3970-9488-458C-B177-3EC73E09DA1E'
AND _latest = 1
If no results are returned then this could explain the error. Quite often repairing the Solution and Reconfiguring the database does not fix the problem. Therefore a workaround would be to export the package to an xml file from a working system and import it into the problem system. If a working system is not available then, for convenience, there is an xml attached to this KB.
NOTE: The attached xml contains information about the NS from which it was exported, but its presence should not affect functionality.
1. Download the attached package xml file
2. In the SMP Console go to "Manage > Organizational Views and Groups > Default > All Resources > Package"
3. Right click on the "Package" node and select "Import"
4. Browse to the saved XML file. Upon import two things might occur. (1) It may say that the object already exists. Click OK and proceed. (2) The import engine may return an error "importing item: undefined". This can usually be ignored.
5. After the Import is completed run the above query again. If it returns one row then the errors should stop showing up in the NS logs.
Attachments
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Legacy ID
51072
Article URL http://www.symantec.com/docs/TECH121961
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