Configuration failed. System.Web.Services.Protocols.SoapException: Failed in SetServiceCredential setting 'AtrsHost' service to use 'Domain\MyUser'.

Article:TECH121970  |  Created: 2010-01-22  |  Updated: 2013-05-14  |  Article URL http://www.symantec.com/docs/TECH121970
Article Type
Technical Solution


Issue



Customer is trying to upgrade from SMP7 SP2 to SP3 via SIM7and during the configuration process the following error appeared in a separate window:

Configuration failed.
System.Web.Services.Protocols.SoapException: Failed in SetServiceCredential setting 'AtrsHost' service to use 'Domain\MyUser'. --> Altiris.NS.Exceptions.SetIdentityException: Failed in SetServiceCredential setting 'AtrsHost' service to use 'Domain\MyUser'. --> Altiris.NS.Exceptions.AeXException: Failed to ChangeServiceConfig. Error=80070430.
   at Altiris.NS.Utilities.AppIdentity.SetServiceCredential(String serviceName, String sUserName, String sPassword)

 

The upgrade process then fails.


Environment



Symantec Management Console 7.0 SP2
Symantec Management Console 7.0 SP3


Cause



During the upgrade process, some services are reset and sometimes removed and recreated if the upgrade process requires it. In this case the upgrade process was not able to set the credentials for this service, usually because the Service was in a hanging or stopping state.


Solution



Note: The following steps where the actual troubleshooting steps. These are share as a possible way to solve this issue as well what else was involved on it.

In this case we had to do the following:

1. Customer noticed that the actual Altiris Object Host (or AtrsHost.exe) service was not longer present in the installed Services. Customer restarted his server but the Altiris Object Host service was still not there.
2. SMP7 SP3 appeared as installed but not configured.
3. We tried to repair NS7 SP3 but it failed because the install process was looking for the  Altiris Object Host service.
4. Since the  Altiris Object Host service was not longer present, we couldn't validate if this error message was related to KB TECH40665 for a similar issue with NS6 and setting credentials for services or if it was related to KB TECH45745.
5. We manually installed the Altiris Object Host service. We used this command line (As KB HOWTO21536 "How to recreate a missing service or reinstall a service with NS7?"suggest):
"C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\InstallUtil.exe" "E:\Program Files\Altiris\TaskManagement\AtrsHost.exe".
6. The Altiris Object Host service was recreated just fine.
7. We ran a repair on NS7 SP3 and it finished just fine. The credentials for Altiris Object Host service were set fine this time.
8. Then we ran aexconfig /configureall and the NS7 SP3 and Solutions were configured. See Article ID: HOWTO9821 "How to run a repair in Notification Server 7"



Legacy ID



51090


Article URL http://www.symantec.com/docs/TECH121970


Terms of use for this information are found in Legal Notices