DS7.1 "Product key" drop-list is blank after selecting an image on a Deploy Image task
| Article:TECH122141 | | | Created: 2010-02-17 | | | Updated: 2010-11-17 | | | Article URL http://www.symantec.com/docs/TECH122141 |
Problem
If you try to create a Deploy Image task, you can't save it until you select a license number (Product Key) for the image. However, the list never populates. Even if you click "new" and enter a license you know is valid, you still don't get anything on the drop list.
Cause
There are a few reasons this might happen:
- If no image has been selected, the Product Key does not populate.
- If there is no matching key for the image "type" you selected, the drop-list will not populate.
- If you have something invalid typed into the Product Key field, nothing will populate
- If there is metadata missing or incorrect for the image you captured, it will either not populate, or populate with the wrong information.
Solution
The answers depend on the issue you are seeing.
1) You must select an image before the product key drop-list will populate.
2) There must be a match between the key-type you entered and the image you captured.
The explanation for this, is that when we capture an image, a table is populated that has the image "type" in it (called the image metadata). (more in #4 below). When you enter a license/Product Key, you enter for a specific image type. If the image metadata doesn't have at least a marginal match to the Product Key you've entered, then it wont show up on the list. We literally filter the drop list for only those that match the image "type" you selected.
3) The drop list is also a type-down list. If you have, somehow, entered something at the top of this list that has no match (i.e. 000000 would have no valid license # match), then nothing will populate on the drop list because you've essentially filtered everything out or off of it.
4) We've seen times where the metadata is either wrong, or missing There are ways to check this:
The following SQL will show you all of your images, along with the OS Type (and a few other potentially useful fields):
SELECT i.name [Image Name],
irc.OSType [OS Type],
irc.ImageTool [Imaged With],
irc.PartitionSize [Partition Info]
FROM Inv_Image_Resource_Component irc
join vItem i on i.Guid = irc._ResourceGuid
The most important information here is in the OS Type field next to the image you're trying to deploy. There has to be a match between that field, and the License Type field in from the query below, which returns all your entered licenses:
SELECT i1.Name [license #], i2.name [License Type], IR.ParentItemGuid [License Type Guid]
FROM ItemReference ir
join Item i1 on i1.Guid = ir.ChildItemGuid
join Item i2 on i2.Guid = ir.ParentItemGuid
WHERE ParentItemGuid in (
SELECT guid
FROM ItemClass
WHERE ClassGuid = '613308bd-3f59-420c-9ff3-2629d75b34d1'
)
In some cases, the "OS Type" field from the first query will be blank, or show "Unknown". In this case, you either captured an OS of an unknown type, or, more likely, did not use "Prepare for Image Capture" in your job. If you don't run that task before capturing the image, this field is not properly populated. Obviously, there is not a match between "Unknown" and an actual product type.
In short, what we're doing, is finding a match on what is in the "OSType" field, and anything after that. In SQL terms, this would be something like "Where LicenseType LIKE 'OSType%'"
Thus, if the OS Type is Windows, just about all of the licenses you've entered would show up. (Trust me, we tested it.)
NOTE: If you are not comfortable with (or able to) running the SQL mentioned above, the attached ZIP file contains 2 reports you can import to the console which show the same information.
~~CAUTION ~~ Modifying SQL directly is NOT recommended and can cause serious issues in NS. If you are not 100% sure of what you are doing, get assistance for the following instructions:
If you are 100% positive you have a valid license, AND that you sysprepped the system, AND that all will be well, go ahead and edit the table Inv_Image_Resource_Component for the row that is incorrect and the license list will populate.
_________________________________________
Finally, if you are using a KMS server in your environment, here are some helpful hints.
- The same license file is used on all Enterprise copies of Vista and Windows 7. Extract this license number and use it, and then be sure your image is configured to find the KMS server.
- For Windows XP, the license number doesn't matter as much because it was before any "serious" effort by MS to track them. You still have to have a valid one for the version though.
Legacy ID
51490
Article URL http://www.symantec.com/docs/TECH122141
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Thank you.