Client task agents are unable to communicate with Remote task Server (Altiris.ClientTask.Server.Exceptions.ClientTaskServerMaxComputerLimitExceededException)

Article:TECH122201  |  Created: 2010-02-24  |  Updated: 2012-07-21  |  Article URL http://www.symantec.com/docs/TECH122201
Article Type
Technical Solution


Issue



Client Task agents are not able to communicate with their designated Task Server. The following message is seen in the logs:

Process: aexnsagent.exe (3652)
Thread ID: 2872
Module: client task agent.dll
Source: Client Task Agent
Description: CTaskServerNetCommsConnection::CheckResponseXml(): The task server returned an error: <![CDATA[System.Exception: An exception occurred while executing the request ---> System.Exception: System.Exception: Unable to register the client 5b6b2139-05fb-4e32-941c-240d4a85d590 ---> Altiris.ClientTask.Server.Exceptions.ClientTaskServerMaxComputerLimitExceededException: Exception of type 'Altiris.ClientTask.Server.Exceptions.ClientTaskServerMaxComputerLimitExceededException' was thrown.
   at Altiris.ClientTask.Server.RemoteClientTaskManager.GetClientStatusAndLock(AltirisResourceGuid resourceGuid, Boolean ignoreMaxComputerLimit, ClientStatus& client, Boolean& created)
   at Altiris.ClientTask.Server.RemoteClientTaskManager.RegisterAndCreateClientRecord(AltirisResourceGuid resourceGuid, String configurationXml, Boolean bLastResort)
   at Altiris.ClientTask.Server.ClientTaskServer.RegisterClient(AltirisResourceGuid resourceGuid, Boolean bLastResort, String configurationXml) AtrsLog:Debug
   --- End of inner exception stack trace ---
   at Altiris.ClientTask.Server.ClientTaskServer.RegisterClient(AltirisResourceGuid resourceGuid, Boolean bLastResort, String configurationXml)
   at Altiris.ClientTask.Server.ClientTaskServer.ProcessRemoteRegisterClient(Hashtable input, Hashtable& output)
   at Altiris.DotNetLib.Sockets.SecureRemoting.SecureRemotingServer.ProcessRequestObject(Object work)
   --- End of inner exception stack trace ---
   at Altiris.DotNetLib.Sockets.SecureRemoting.SecureRemotingClient.SendRequestI(String service, Hashtable input)
   at Altiris.DotNetLib.Sockets.SecureRemoting.SecureRemotingClient.SendRequest(String service, Hashtable input)
   at Altiris.ClientTask.Server.HttpHandlers.WebClientApiManager.ProcessRegister(XmlTextWriter wr, NameValueCollection queryValues, Stream requestStream, Int32 contentLength)
   at Altiris.ClientTask.Server.HttpHandlers.Register.WriteResponse(XmlTextWriter wr)
   at Altiris.TaskManagement.Common.XmlHttp.BaseXmlXmlHttpCallback.WriteResponseRaw(XmlTextWriter xwr)
   at Altiris.TaskManagement.Common.XmlHttp.BaseXmlHttpCallback.ProcessRequest(HttpContext context)]]>

and/or

Process: aexnsagent.exe (3652)
Thread ID: 2872
Module: client task agent.dll
Source: Client Task Agent
Description: Unable to post file to server, error 8000ffff


Environment



Symantec Management Platform SP3

Task Server 7.0 SP3


Cause



A Task Settings policy had been set that prohibited Task Servers from servicing more than "X" number of clients

Solution



Configure the Task Settings to permit an appropriate number of task clients per Task server.

To configure Task Settings:

1) Open the NS Console
2) Navigate to Settings -> Notification Server -> Site Server Settings
3) Expand Site Management -> Settings -> Task Service -> Settings
   ...You should see a list of all Task Settings policies you currently have configured
4) Review the setting policies to ensure that the "Maximum computers to manage per Task Server" value is set appropriately for the task servers that use the respective policy.
   ...Ensure that there is no over-lap between Task Server settings policies. Each policy should target its own distinct group of Task servers.

Note:: If you encounter the error listed above and you have already built out your Task Servers, try increasing the "Maximum computer to manage per Task server" to 5000 in the Policy that governs the Notification Server. There has been at least one case where this had to be set Temporarily to allow the task clients to communicate correctly with their respective Remote task server.

Legacy ID



51627


Article URL http://www.symantec.com/docs/TECH122201


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