The setup has detected critical error(s). The installation will exit now! When applying the Cumulative Hotfix (CHF) to CCS Reporting and Analytics

Article:TECH122501  |  Created: 2010-01-18  |  Updated: 2011-01-27  |  Article URL http://www.symantec.com/docs/TECH122501
Article Type
Technical Solution


Problem





Symptoms
 

1. The error occurs after applying a CHF to the Application Server.
2. The CHF fails to rollback to previous installation files with the
following error:

Activity 'Name= CSM.InstallAppServer; Display Name = Application Server; Dependency = After CSI.Anchor.CSIExecuteSequence; FailureBehavior = FailAndRollbackActivity' failed: MsiApplyPatchw failed while installing C:\documents and settings\svcscc\local settings\temp\1\csmsetup\media\application server\appserver.msp

Reason: fatal error during installation.

 


Error



The setup has detected critical error(s).  The installation will exit now!

Details:

Activity 'Name= CSM.InstallAppServer; Display Name = Application Server; Dependency = After CSI.Anchor.CSIExecuteSequence; FailureBehavior = FailAndRollbackActivity' failed: MsiApplyPatchw failed while installing C:\documents and settings\svcscc\local settings\temp\1\csmsetup\media\application server\appserver.msp
 


Environment



CCS R&A 9.0.1 when applying November

CCS R&A 9.0.1 when applying 2010-4


Cause



The Microsoft SQL Server Agent service was running as a Domain account and did not have the sysadmin role on the SQL Server database. This is a requirement for installing any component during the installation or hotfix.


Solution




Add the Domain user that is used as the service user for
the Microsoft SQL Server Agent to the sysadmin role within
the Microsoft SQL Server database.



 



Legacy ID



2010011809383453


Article URL http://www.symantec.com/docs/TECH122501


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