SWG fails to block web pages in inline mode

Article:TECH123589  |  Created: 2010-01-01  |  Updated: 2011-03-02  |  Article URL http://www.symantec.com/docs/TECH123589
Article Type
Technical Solution


Issue



Using a client machine behind Symantec Web Gateway (SWG) 4.5.x, you are able to receive the Blacklist test page on http://testwebgateway.com. You seek to prevent SWG from displaying this test page and thereby prove that the URL Filtering works on the local SWG Appliance.

Symptoms
When you attempt to navigate to http://testwebgateway.com from a client behind Symantec Web Gateway, you are able to receive the page. When this happens, Custom Reports shows an Action of “Monitored” and a policy of “Default”.

Alternatively, when you are able to navigate to all pages without SWG blocking any of them. When this happens, you also do not see any entries on the Custom Report for the web sites you visit.


 


Cause



There are multiple possible causes for this behavior.


Solution



  1. If SWG fails to block pages after initial setup and configuration, troubleshoot the configuration.
  2. If SWG blocks pages, but then fails to block pages after an update, troubleshoot the update.



To troubleshoot configuration

  1. Add the local network to "Internal Network Configuration" on the Administration> Configuration> Network page within the SWG web interface.
  2. Click Save.
  3. On the Administration> Configuration> Operating Mode, click Blocking.
  4. Click Save.
  5. On Policies> Configuration, Add or Edit a Policy
  6. To add a Content Filter Exception, click "Add an Exception"
  7. In "Domain name/IP Address", type the domain of the web site or the IP address you seek to block.
  8. Under "Action", click "Block".
  9. In Description, type a brief description.
  10. Click Save


To test, navigate to the blocked web site using a browser on a client machine behind the SWG Appliance in inline mode. You should now receive a URL Block page.


To troubleshoot updates

  1. To restart the SWG appliance, click Administration> Configuration. Click Maintenance. Click Reboot.
  2. Monitor whether the appliance is in an up state by using the ping command from another machine.
  3. When SWG is done restarting, test. If you are now able to block pages with SWG, stop here.
  4. To revert the database update and re-apply, click Administration> Updates. Within the section "Web Gateway Database Updates", click "Revert to Previous Version".
  5. To re-download and re-apply the database update, within the section "Web Gateway Database Updates", click "Update".
  6. When SWG completes the database update, test. If you are now able to block pages with SWG, stop here.
  7. To revert the software update and re-apply, click Administration> Updates. Within the section "Web Gateway Software Updates", click "Revert to Previous Version".
  8. To re-download and re-apply the software update, within the section "Web Gateway Software Updates", click "Update".
  9. Monitor whether the SWG appliance is in an up state by using the ping command from another machine,
  10. When SWG completes the software update and reboot, test. If you are now able to block pages with SWG, stop here.





 



Legacy ID



2010030115182954


Article URL http://www.symantec.com/docs/TECH123589


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