Large amount of items Vault Admin Console under Personal Store Management the does not display results

Article:TECH126302  |  Created: 2010-01-29  |  Updated: 2013-08-29  |  Article URL http://www.symantec.com/docs/TECH126302
Article Type
Technical Solution

Product(s)

Issue



When there are more than a 100,000 items to return in the Vault Admin Console (VAC) under Personal Store Management the request takes a lot of time to return and does not display the results, instead displays nothing.


Error



Event ID: 8391
Description:
The EnterpriseVault.DirectoryService object reported an error.| |Ran out of memory| |

and

Event ID: 13360
Description: An error was detected while accessing the Vault Database 'EnterpriseVaultDirectory' (Internal reference: .\ADODataAccess.cpp (CADODataAccess::ExtractFromRecordsetToVariant) [lines {1331,1338,1352}] built Jul 3 19:52:25 2009): SQL Command: SELECT PstComputerEntryId,ComputerName,DomainName,ExchangeMailboxEntryId,LastHardDiskSc an,LastRegistryScan,LastNetworkFailure,SearchThisComputer,HardDiskSearchInProgre ss,RegistrySearchInProgress,HardDiskFailureText,RegistryFailureText,ComputerType ,PstDomainEntryId,DomName,SearchThisDomain,SiteEntryId,DnsDomainName FROM PstComputer LEFT JOIN PstDomain ON DomainName = DomName WHERE (ComputerName LIKE ?) AND (DomainName LIKE ?) AND (SiteEntryId = ?) ORDER BY ComputerName

Additional Microsoft supplied information:
Source: Provider
Number: 0x8007000e
SQL State:
Native Error: -2147024882
HRESULT 0x8007000e
Description: Not enough storage is available to complete this operation.


Cause



When the Personal Store Management Computer or Files list) attempts to display the list in the window the request may not return any results if there is more than 100,000 items. Within the Event Viewer log an Event ID 8391 with a "Ran out of memory" error will be generated and Event ID 13360 may also be seen. 


Solution



There is no workaround available at this time.


Symantec Corporation has acknowledged that the above-mentioned issue is present in the current version(s) of the product(s) mentioned at the end of this article. Symantec Corporation is committed to product quality and satisfied customers.

There are no plans to address this issue by way of a patch or hotfix in the current or previous versions of the software at the present time. However, the issue is currently scheduled to be addressed in the next major revision of the product. Please be sure to refer back to this document periodically as any changes to the status of the defect will be reflected here.  Please note that Symantec Corporation reserves the right to remove any fix from the targeted release if it does not pass quality assurance tests.  Symantec's plans are subject to change and any action taken by you based on the above information or your reliance upon the above information is made at your own risk.

Please contact your Symantec Sales representative or the Symantec Sales group for upgrade information including upgrade eligibility to the release containing the resolution for this issue.  For information on how to contact Symantec Sales, please see  http://www.symantec.com/ .

 


Supplemental Materials

SourceETrack
Value1851891
Description

Vault Admin Console does not show all items it should within the Personal Store Management


SourceEvent ID
Value8391
Description

The EnterpriseVault.DirectoryService object reported an error.| |Ran out of memory| |


SourceEvent ID
Value13360
Description

An error was detected while accessing the Vault Database 'EnterpriseVaultDirectory' (Internal reference: .\ADODataAccess.cpp (CADODataAccess::ExtractFromRecordsetToVariant) [lines {1331,1338,1352}] built Jul 3 19:52:25 2009): SQL Command: SELECT PstComputerEntryId,ComputerName,DomainName,ExchangeMailboxEntryId,LastHardDiskSc an,LastRegistryScan,LastNetworkFailure,SearchThisComputer,HardDiskSearchInProgre ss,RegistrySearchInProgress,HardDiskFailureText,RegistryFailureText,ComputerType ,PstDomainEntryId,DomName,SearchThisDomain,SiteEntryId,DnsDomainName FROM PstComputer LEFT JOIN PstDomain ON DomainName = DomName WHERE (ComputerName LIKE ?) AND (DomainName LIKE ?) AND (SiteEntryId = ?) ORDER BY ComputerName

Additional Microsoft supplied information:

Source: Provider
Number: 0x8007000e
SQL State:
Native Error: -2147024882
HRESULT 0x8007000e
Description: Not enough storage is available to complete this operation. 



Legacy ID



341590


Article URL http://www.symantec.com/docs/TECH126302


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