KNOWN ISSUE: DS7.1: Computers panes (Top left 2) in the DS Portal appear blank - all other features work.

Article:TECH127217  |  Created: 2010-03-24  |  Updated: 2010-04-12  |  Article URL http://www.symantec.com/docs/TECH127217
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Article Type
Technical Solution


Issue



When you launch the Deployment Portal within the Notification Server console, you may see the upper-left 2 panes empty, though the lower left and right panes work fine, along with all other features.  If all panes are blank, this is a different issue logged here (KB 51549) and generally only seen when running the console remotely.  This issue can occur on the NS as well as remote consoles.  Additionally, 60 seconds after launching the portal (the default time-out for Silverlight), you'll get an error in the lower left corner of the Browser that reads something like this:

Message: Unhandled Error in Silverlight Application [Async_ExceptionOccurred]

This is a generic error saying something didn't work, though the details do give some indication on where the problem exists.

Additionally, you may see an error on your SQL server in the app event logs saying that access was denied for user Anonymous.

Environment



DS 7.1 Portal

Cause



This is caused by impersonation errors in the SilverLight console.

Solution



Symantec Development has released a point fix for this issue (intructions to install are detailed below).  These files will be included in the next maintenance pack due 2nd quarter 2010.

  Installation instructions:

  1. Download and extract 'Portal Issues.zip' attached to this KB to a temporary location on your hard drive.  E.g  C:\portal fix

  2. Make a backup copy of all files and folders located in the ‘<NS installation drive>:\Program Files\Altiris\Deployment\DSPortalWCFService’ folder.  E.g.  ‘<NS installation drive>:\Program Files\Altiris\Deployment\DSPortalWCFService\backup’

  3.  Copy ‘web.config’ from ‘C:\portal fix’ to the  ‘<NS installation drive>:\Program Files\Altiris\Deployment\DSPortalWCFService’ folder

  4.  Copy ‘Altiris.Deployment.DSPortalWCFService.dll’ from ‘C:\portal fix’ to ‘<NS installation drive>:\Program Files\Altiris\Deployment\DSPortalWCFService\bin’

  5.  Make a backup copy of  ‘<NS installation drive>:\Program Files\Altiris\Deployment\Web\ClientBin\DSPortal.xap’  E.g. ‘<NS installation drive>:\Program Files\Altiris\Deployment\Web\ClientBin\backup’

  6. Copy ‘DSPortal.xap’ from ‘C:\portal fix’ to ‘<NS installation drive>:\Program Files\Altiris\Deployment\Web\ClientBin
  7. Restart 'IIS Admin Service'


Attachments

portal issue.zip (899 kBytes)

Supplemental Materials

SourceDEFECT
ValueETK 2000272
DescriptionLogged in Etrack (Symantec) database

Legacy ID



52096


Article URL http://www.symantec.com/docs/TECH127217


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