ERROR: "Object TaskServerHandler is not installed" - Client Task Agent becoming unregistered

Article:TECH127269  |  Created: 2010-03-30  |  Updated: 2013-10-28  |  Article URL http://www.symantec.com/docs/TECH127269
Article Type
Technical Solution

Product(s)

Issue



Tasks will not run on a client machine with a Console error message "Object TaskServerHandler is not installed".  On the Task Status tab in the Agent UI, the Status is listed as 'Agent not Initialized'.

 

 


Error



<event date="XXX XX XX:XX:XX" severity="2" hostName="<HOSTNAME>" source="Agent" module="AeXNSAgent.exe" process="AeXNSAgent.exe" pid="4236" thread="4560" tickCount="1266053203"><![CDATA[Object TaskServerHandler is not installed: Invalid class string (-2147221005). This situation should be resolved once the agent rollout has been completed.]]></event>

 

 


Environment



Symantec Management Platform SP4, SP5

Client Management Suite SP1, SP2

 

 


Cause



This is caused by the Client Task Agent.dll not being registered with the Operating System.

Most commonly this has been observed to be caused by an upgrade to the product/agent and results immediately thereafter.  However, it has been observed under other circumstances/environments in which case the exact cause has not been determined.

 

 


Solution



 

The Client Task Agent.dll must be re-registered with the system.  This is done by using the following command at a command prompt or script: regsvr32 <filename>.  The default path to the file is: C:\Program Files\Altiris\Altiris Agent\Agents\Client Task Agent\ Client Task Agent.dll.
EX: Use of the regsvr32 command to register the Clietn Task Agent.dll

 

 

 

 

 

 

 

 

 

 

 



Legacy ID



52220


Article URL http://www.symantec.com/docs/TECH127269


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