Backup Exec (BE) 2010 push install of the Backup Exec Remote Agent and/or Desktop Laptop Agent (DLO) to a Remote Windows Server fails with error: "Error connecting to the remote server. Ensure the server is available, has WMI enabled, and is not blocked by a firewall. 1603."

Article:TECH128062  |  Created: 2010-01-29  |  Updated: 2013-10-25  |  Article URL http://www.symantec.com/docs/TECH128062
Article Type
Technical Solution


Issue



Backup Exec (BE) 2010 push install of the Backup Exec Remote Agent and/or Desktop Laptop Agent (DLO) to a Remote Windows Server fails with error: "Error connecting to the remote server. Ensure the server is available, has WMI enabled, and is not blocked by a firewall. 1603."

 


Error



Error connecting to the remote server. Ensure the server is available, has WMI enabled, and is not blocked by a firewall. 1603

Windows System Event log on the remote Windows Workstation or Server shows below:

Fig 1
  

Remote Agent push log <Hostname>_Push.log for the specific remote server or workstation shows below error:
ERROR: Exception: System.Runtime.InteropServices.COMException (0x800706BA): The RPC server is unavailable. (Exception from HRESULT: 0x800706BA) at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo) at System.Management.ManagementScope.InitializeGuts(Object o) at System.Management.ManagementScope.Initialize() at Symantec.IFrameSDK.NetPush.WMIMethods.a(ManagementScope& A_0, String A_1, String A_2, String A_3, String A_4)

Location of Remote Agent push log:

  •  Windows Server 2008: X:\ProgramData\Symantec\Backup Exec\PushLogs
  • Windows Server 2003: X:\Documents and Settings\All Users\Application Data\Symantec\Backup Exec\Logs

Cause



This error can be caused by insufficient DCOM privileges for the account used to start the DCOM Server Process Launcher.

 


Solution



*Note: DCOM permissions should only be configured by a Microsoft Support Professional or by an individual that thoroughly understands the effects of such changes.

1. Take note of the exact 'CLSID' and 'user' noted within the description of the Windows DCOM System Event. (See Figure 2)

Fig 2

 

In this example, we see the CLSID to be {555F3418-D99E-4E51-800A-6E89CFD8B1D7}

2. Click Start | Run | Regedit

Warning: Incorrect use of the Windows registry editor may prevent the operating system from
functioning properly. Great care should be taken when making changes to a Windows registry. Registry
modifications should only be carried-out by persons experienced in the use of the registry editor
application. It is recommended that a complete backup of the registry and workstation be made prior to
making any registry changes.

Goto the following registry key:
HKEY_CLASSES_ROOT\CLSID\

Locate the 'AppID' String Value key and note the Data Value. (See Figure 3)

Fig 3

 

The AppID string indicates a value of {B1B9CBB2-B198-47E2-8260-9FD629A2B2EC} and matches what is shown in the Event Properties window.

3. Click Start | Run | dcomcnfg

4. A Windows Security Alert pop-up will appear, click Unblock.

5. From the dcomcnfg Console Root select Component Services | Computers | My Computer | DCOM Config

Locate the DCOM Object that matches the Value Data from the 'AppID' Registry Value Data noted in step 2. (See Figure 4)

Fig 4

 


6. Right Click on the DCOM Object that matches and select 'Properties' and select the 'Security' tab

Fig 5

 

7. Under 'Launch and Activation Permissions' select the 'Customize' radio button and click Edit

Fig 6

 

8. Add the User 'LOCAL SERVICE' to the Group or user names list and give Allow access for these permissions:
 
Local Launch
Remote Launch
Local Activation
Remote Activation
 
Fig 7

 

Click 'Apply' and 'OK'
 
The 'LOCAL SERVICE' user is added in this example because the 'Local System' was selected to be used for the 'DCOM Server Process Launcher' service as shown in the Windows Services Applet. (See Figure 8)

Fig 8

 

9. Reboot the Workstation or Server wherein this DCOM change occurred.

10. Re-attempt the push install

System account could be blocking the setup.
 
If a push/local install of RAWS fails with the error 1603 still and is accompanied by the below event log on the server
Source: MSI Installer, Event ID:1606 Could not access network location 0
 
-Login to the server as the local system administrator and try the RAWS installation
 


Supplemental Materials

SourceEvent ID
Value10016


Legacy ID



348013


Article URL http://www.symantec.com/docs/TECH128062


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