Archive Explorer opens with a 30 second delay when opening from within Microsoft Outlook the first time. All subsequent calls are successful and fast

Article:TECH129441  |  Created: 2010-01-29  |  Updated: 2014-03-31  |  Article URL http://www.symantec.com/docs/TECH129441
Article Type
Technical Solution

Product(s)

Environment

Issue



When Microsoft Outlook is opened there is a 30 second delay when opening Archive Explorer from within Microsoft Outlook the first time. All subsequent calls to Archive Explorer are successful and open fast, only the initial connection has the delay


Error



No specific error is displayed to the end user


Environment



This issue has been seen in Terminal Services and Citrix environments


Cause



1. Start Microsoft Outlook
2. Ensure that the Enterprise Vault Client logging is set to Maximum tracing
3. Restart Microsoft Outlook if the logging level in Step 2 was changed
4. Click on either Archive Explorer or Integrated Search
5. Open the Client log and search for the line:-

pCmdBars->Count = ??

If there is a delay after the above line then this technote is relevant. For example a 30 second delay would show as follows in the client trace:-

06/04/2010 20:40:08.493[1148]: pCmdBars->Count = 23
06/04/2010 20:40:38.965[1148]: Our control was created

 


Solution




Workarounds Available

1. Make the user a local administrator of the client
2. Start the Telephony Service
3. Change the Enterprise Vault policy setting Launch Archive Explorer or Search behavior to Separate Browser
 
Permanent Fix
 
To permanently fix this permissions need to be assigned to the Telephony Service. It is recommended that this be achieved via Group Policy. For Example:-
 
1. Create a Group Policy called AEDelay
2. Go to the setting - Computer Configuration - Windows Settings - Security Settings - System Services
3. Find the Telephony Service and double click on it.
4. Click Define this policy setting
5. If the services is not requires you can disable it at this stage
6. Click on Edit Security
7. Change INTERACTIVE from Read to Full Control
8. Click Apply
9. Either run gpupdate /force or wait for the GPO to be automatically applied
10. Test the client to ensure the delay is no longer experienced

Supplemental Materials

SourceETrack
Value2016405
Description

When Microsoft Outlook is opened there is a 30 second delay when opening Archive Explorer from within Outlook the first time. All subsequent calls to AE are successful and open fast, only the initial connection has the delay



Legacy ID



351701


Article URL http://www.symantec.com/docs/TECH129441


Terms of use for this information are found in Legal Notices