How to troubleshoot virtual machine VSS snapshot and quiesce issues during VMware backups.
| Article:TECH129724 | | | Created: 2010-01-06 | | | Updated: 2012-12-12 | | | Article URL http://www.symantec.com/docs/TECH129724 |
Problem
How to troubleshoot virtual machine VSS snapshot and quiesce issues during VMware backups.
Error
0xe000959a - An attempt to take a snapshot of a virtual machine failed because it was unable to quiesce an application.
Final error category: Resource Errors
For additional information regarding this error refer to link V-79-57344-38298
Cause
Quiesce and other snapshot errors during virtual machine backups can occur from:
Solution
| VSS (VMware Tools) | Symantec VSS Provider |
|---|---|
| Service: VMware Snapshot Provider | Service: Backup Exec VSS Provider |
| VMware distributes a VSS snapshot provider with VMware Tools | Installed by pushing RAWS (Remote Agent for Windows Systems) or manual installation |
| Install: http://kb.vmware.com/kb/1008965 | Push Install: HOWTO22499 |
| Manual Install: HOWTO23038 | |
| Uninstall: TECH129864 | Uninstall: TECH130940 |
The following information determines which snapshot provider should be installed:
It is recommended to install and use the Backup Exec VSS Provider if:
When installing the Backup Exec Remote Agent on a guest machine for GRT enabled virtual machine backups, the VMware Snapshot provider is automatically uninstalled and the BE VSS Provider is installed (this is why a reboot is required). The Backup Exec VSS Provider cannot exist in a guest alongside the VMware Snapshot Provider as with both installed on a guest will cause quiesced snapshots to hang the guest and timeout. Once the Backup Exec Remote Agent is installed, thus installing the BE VSS Provider, do NOT re-install the VMware Tools VSS Provider as this will re-create the conflict condition and cause quiesce and/or snapshot errors. To see which providers are installed, launch Windows Services on the guest machine and confirm one of services from the table above are listed. If more than one provider is installed, determine which provider is needed and follow the steps below to uninstall the other:
Note : If the BE VSS Provider is correctly installed on the guest machine, the BeVssProvider service will show in Windows services and BE VSS Provider will be listed under the "vssadmin list providers" command ONLY during a backup.
If either is seen and no backups are running of the guest machine, there is either an issue with:
A test to confirm snapshots are working correctly within the virtual environment is to run a snapshot from inside vCenter/vSphere client.
Snapshot File is unable to fit into the specified Datastore:
Have the customer create a quiesced snapshot in the vSphere console for the virtual machine with that is failing with the error. If it produces: File<unspecifi-ed filename> is largerthan themaximumsizesupportedby datastore'<unspecifi-ed datastore> and the snapshot fails then have him review:
http://kb.vmware.com/kb/1012384
If the customer requires further assistance with this issue have them contact VMware Support to troubleshoot this issue.
|
|
| Source | UMI |
| Value | V-79-57344-38299 |
| Description | 0xe000959b - An attempt to take a snapshot of a virtual machine failed because it was unable to quiesce a file system. |
| Source | UMI |
| Value | V-79-57344-38298 |
| Description | Final error: 0xe000959a - An attempt to take a snapshot of a virtual machine failed because it was unable to quiesce an application. |
| Source | UMI |
| Value | V-79-57344-38260 |
| Description | 0xe0009574 - Unable to create a snapshot of the virtual machine. The virtual machine may be too busy to quiesce to take the snapshot. |
| Source | Error Code |
| Value | 0xe0009574 |
| Description | Unable to create a snapshot of the virtual machine. |
| Source | Error Code |
| Value | 0xe000959b |
| Description | An attempt to take a snapshot of a virtual machine failed because it was unable to quiesce a file system. |
Related Articles
Legacy ID
352025
Article URL http://www.symantec.com/docs/TECH129724
Terms of use for this information are found in Legal Notices









Thank you.