How to restore a Ghost Solution Suite 2.5.1 database backup manually captured from a Ghost Console 32-bit machine to a 64-bit machine.
| Article:TECH131820 | | | Created: 2010-01-19 | | | Updated: 2010-01-28 | | | Article URL http://www.symantec.com/docs/TECH131820 |
Problem
You need to restore a manual backup of the Ghost Console database from a 32-bit machine to a 64-bit machine.
The following KB includes the instructions on how to manually backup a Ghost Console Database:
Title: 'Manually backing up the Ghost Console database from Ghost Solution Suite 2.5.1'
Document ID: 2010011111365360
> Web URL: http://service1.symantec.com/support/on-technology.nsf/docid/2010011111365360?Open&seg=ent
You may also refer to the following document:
Title: 'How to restore the database backup you manually captured from the Ghost Console from Ghost Solution Suite 2.5.1'
Document ID: 2010011111493160
> Web URL: http://service1.symantec.com/support/on-technology.nsf/docid/2010011111493160?Open&seg=ent
Symptoms
The console is unable to connect to the database upon start up.
The clients are not populating the new console after restoring the database.
Cause
Registry keys are created differently in 32 and 64-bit O/S. - The 32-bit O/S registry key file location is: "HKLM\SOFTWARE\Symantec Ghost\NGserver" - The 64 bit O/S registry key file location is: "HKLM\SOFTWARE\Wow6432Node\Symantec\Symantec Ghost\NGServer". When you try to import a 32-bit registry key into a 64-bit O/S, the registry location will not be in the correct location. Therefore, the database server service will not start. This problem occurs on all 64-bit O/S when restoring a database from a 32-bit O/S. Restoring a database from 32-bit O/S to another 32-bit O/S will work properly. A database restored from a 64-bit O/S to another 64-bit O/S will also work properly.
Solution
Install the Ghost Console and Standard Tools onto the 64-bit machine.
The same build number should be installed on the 64-bit machine as is on the 32-bit machine where the database is backed up.
Examples:
Ghost 11.5, build 2113 on 32-bit machine Ghost 11.5, build 2113 on 64-bit machine
Ghost 11.5, build 2266 on 32-bit machine Ghost 11.5, build 2266 on 64-bit machine
Before opening the Ghost Console, you will need to modify the registry key HKEY_LOCAL_MACHINE (HKLM).
"HKLM\SOFTWARE\Symantec\Symantec Ghost\NGserver" to
"HKLM\SOFTWARE\Wow6432Node\Symantec\Symantec Ghost\NGServer".
NOTE: Best practice is to create a backup of the registry before making any changes in the Windows O/S Registry.
Instructions on how to backup a Registry file:
1. Go to Run.
2. Type in Regedit and click on OK.
3. Click on File > Export and specify a name and location to save the file.
Before modifying the registry a Windows Service must be shut down.
1. Click Start > Run > Services.msc > OK
2. Right-click on the following services and select Stop:
- a. Symantec Ghost Configuration Server
b. Symantec Ghost Database Service Wrapper
2. R-click the Symantec folder
3. Click on Export and save it to the Desktop.
4. R-click the Registry (.reg) file just saved on the Desktop.
5. Click on Edit.
6. Type Wow6432Node\ in the path in front of the Symantec folder. It should look like: HKEY_LOCAl_MACHINE\SOFTWARE\Wow6432Node\Symantec\Symantec Ghost\NGServer.
7. Copy Wow6432Node\ in front of the Symantec folder on any other lines that pertain to Ghost.
8. Click on File > Save.
9. Double-click on the Registry file on the Desktop.
10. Verify the entries are in the following order: "HKLM\SOFTWARE\Wow6432Node\Symantec\Symantec Ghost\NGServer"
- a. pubkey.crt
b. privkey.crt
3. Click Start > Run > Services.msc > OK
4. Right-click on the following services and select Start:
- a. Symantec Ghost Configuration Server
b. Symantec Ghost Database Service Wrapper
If both services start and report no error, open the Ghost Console and manually verify the information from your database backup has been successfully imported.
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| Source | ETrack |
| Value | 899, Titan Case # 411-872-099 |
Legacy ID
2010041915064360
Article URL http://www.symantec.com/docs/TECH131820
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