Using a ServiceDesk Workflow project in Workflow 7 results in the error "Component is bound to service context [ServiceDesk] but the license provider for this context failed to provide a license"

Article:TECH133465  |  Created: 2010-07-14  |  Updated: 2010-07-14  |  Article URL http://www.symantec.com/docs/TECH133465
Article Type
Technical Solution


Issue



A ServiceDesk Workflow project has been copied to a Worflow 7 server. When trying to use this, licensing errors occur, such as "Component is bound to service context [ServiceDesk] but the license provider for this context failed to provide a license".

Cause



Incorrect version of Workflow is being used.  The version of Workflow Designer installed from the Workflow 7 installer does not provide the proper licensing assemblies for use with projects that use ServiceDesk specific components.  Nor does this version of Workflow Designer install the necessary component libraries for use in developing ServiceDesk projects.

Solution



Using Workflow 7 to create or modify ServiceDesk Workflow projects is not supported. Use only the version of Workflow that comes with ServiceDesk. For more information, please refer to the following articles:

Can Workflow 7 be used to develop ServiceDesk projects?
https://kb.altiris.com/article.asp?article=53773&p=1

How to install ServiceDesk's Workflow Designer onto a client computer
https://kb.altiris.com/article.asp?article=53818&p=1

Legacy ID



53775


Article URL http://www.symantec.com/docs/TECH133465


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