Access Errors when using Symantec AntiVirus for Network Attached Storage 5.2 on Windows 2008

Article:TECH133915  |  Created: 2010-01-14  |  Updated: 2013-12-04  |  Article URL http://www.symantec.com/docs/TECH133915
Article Type
Technical Solution

Product(s)

Issue



When scanning a lot of files at the same time, many scans come back with scan errors/access errors. When using the Symantec Scan Engine API, the API should specifically report access errors.


Cause



This issue is caused by the Microsoft Redirector for SMB2, which is caching directory metadata. This caching is time based and Microsoft does not guarantee the consistency of this cache. SMB2 was added in Windows 2008, this issue should be specific to Symantec AntiVirus for Network Attached Storage installed on Windows 2008.


Solution



The solution is to disable this cache when using SMB2, or to disable SMB2. To disable the Microsoft Redirector cache,

  1. Open the Registry Editor on the Symantec Scan Engine server.
  2. Go to, HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Lanmanworkstation\Parameters.
  3. Create entry "DirectoryCacheLifetime", and set it to "0".
  4. Create entry "FileInfoCacheLifetime", and set it to "0".
  5. Also create entry, "FileNotFoundCacheLifetime" to "0".
  6. Close the registry, and restart the Server.




Technical Information
Please contact Support for more information.

 



Legacy ID



2010061422333454


Article URL http://www.symantec.com/docs/TECH133915


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