Altiris Agent push errors
| Article:TECH13407 | | | Created: 2006-04-05 | | | Updated: 2012-03-27 | | | Article URL http://www.symantec.com/docs/TECH13407 |
Problem
- Failed to copy Altiris Agent install service.
- No network provider accepted the given network path
- The network path was not found.
Process: aexsvc.exe (280)
Thread ID: XXXX
Module: AltirisNativeHelper.dll
Source: Altiris.NS.Utilities.RemoteServiceMgr
Description: Failed to copy the eXpress Client service to \\XX.XX.XX.XX\ADMIN$\AeXSWDInstSvc.exe. Error:The network path was not found.
This type of failure can occur if a client push is currently in progress or has completed but some files are still locked. This problem can typically be solved by rebooting the computer
Process: aexsvc.exe (280)
Thread ID: XXXX
Module: AltirisNativeHelper.dll
Source: Altiris.NS.Utilities.RemoteServiceMgr
Description: Failed to copy the eXpress Client service to \\XX.XX.XX.XX\ADMIN$\AeXSWDInstSvc.exe. Error:The process cannot access the file "\\XX.XX.XX.XX\ADMIN$\AeXSWDInstSvc.exe" because it is being used by another process. This type of failure can occur if a client push is currently in progress or has completed but some files are still locked. This problem can typically be solved by rebooting the computer
Process: aexsvc.exe (280)
Thread ID: XXXX
Module: AltirisNativeHelper.dll
Source: Altiris.NS.Utilities.RemoteServiceMgr
Description: Failed to copy the eXpress Client service to \\XX.XX.XX.XX\ADMIN$\AeXSWDInstSvc.exe. Error:Access to the path "\\XX.XX.XX.XX\ADMIN$\AeXSWDInstSvc.exe" is denied.
Error
Environment
Notification Server 6.x and 7.x
Cause
Agent Push failures can be caused by the following items:
- The Admin$ share is not accessible.
- Simple file sharing is enabled on XP clients.
- DNS is not resolving names correctly.
- Windows Firewall is enabled on the client computer (could not ping the client from the Notification Server).
- The computer does not have a status of "active" in the console.
Solution
-
At the computer where you want to install the Altiris Agent:
- Verify that the Admin$ share defined and accessible. Right-click the My Computer icon and click Manage. In the Computer Management window, click System Tools > Shared Folder > Shares. In the right pane, verify that the ADMIN$ share is displayed. If it is not, you will have to create it with the shared path C:\Windows.
- Make sure that Simple File Sharing is disabled. Open My Computer and click on Tools > Folder options > View tab, then scroll to the bottom of the list and uncheck the option Use simple file sharing.
- Make sure the Windows Firewall is turned off. Click Start > Control Panel > Security Center. In the Manage security settings for section, click Windows Firewall. When the Windows Firewall window appears, click Off and then click OK.
- At the Notification Server, using the credentials that will be used to push out the Altiris Agent:
- Try to access the Admin$ on the client computer by clicking Start > Run and typing \\computername\ADMIN$.
- See if DNS is working properly by pinging the client computer. Open a command window and enter:
ping -a <IP address>
If DNS is working properly, the "-a" should cause the correct Computer Name to be returned as follows:
Pinging <Computer Name> [IP address] with 32 bytes of data.
If the computer cannot be pinged and you cannot access the Admin$ share, it is likely a DNS issue and will need to be handled by the network admin for the network affected.
- If the target machine is Server 2003, ensure the guest user account is enabled
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Legacy ID
21574
Article URL http://www.symantec.com/docs/TECH13407
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