Messages Not Delivered with Error Message "...unhandled exception 'InvalidCharsetException"

Article:TECH134605  |  Created: 2010-01-01  |  Updated: 2014-07-08  |  Article URL http://www.symantec.com/docs/TECH134605
Article Type
Technical Solution


Issue



Email messages are not delivered.


Symptoms

  • The sender receives the error "554 5.6.0 Invalid message content"
     
  • Windows Application Event Log contain entries similiar to the following:

 

 


Event Type: Warning
Event Source: MSExchange Extensibility
Event Category: MExRuntime
Event ID: 1051
Date: 7/8/2010
Time: 9:05:07 AM
User: N/A
Computer: EXCHANGE2K7HUB
Description:
Agent 'SMSMSESMTPAgent' caused an unhandled exception 'InvalidCharsetException: Character set name (ISO8859-15) is invalid or not installed.' while handling event 'OnEndOfData'

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

 

 

 

NOTE:  The character set name in the message may be different.


 

Conditions

 

  • Character set mentioned in the error message is not valid.

The example error message above is ISO8859-15.  This is not a valid character set.  The valid character set is ISO-8859-15 (see this article: http://en.wikipedia.org/wiki/ISO/IEC_8859-15).

 


Cause



This is caused by an Symantec Mail Security for Microsoft Exchange receiving an improperly formatted Character set name in the email message. For example, the invalid character set name is ISO8859-15 and the valid character set name is ISO-8859-15.

 


Solution



This issue is fixed in SMSMSE 6.5.5. Upgrade to 6.5.5 to resolve this issue.

Workaround


NOTE: This workaround is only applicable to customers that do not use Symantec Premium Antispam.

To check if you are using Symantec Premium Antispam:

  1. Open the SMSMSE console
  2. Go to Policies > Premium Antispam Settings
  3. "Enable Symantec Premium Antispam" will be checked

Disable the SMSMSESMTPAgent which is responsible for handling Symantec Premium Antispam scanning. These steps should be performed on all Hub and Edge servers experiencing the problem.
 

  1. Open the Exchange Management Shell.
  2. Enter the command Disable-TransportAgent -Identity SMSMSESMTPAgent.
  3. Answer yes when prompted.
  4. Enter the command Get-TransportAgent to verify the SMSMSESMTPAgent has been disabled.
  5. Close the Exchange Management Shell.
  6. Open the Services mmc.
  7. Restart the Microsoft Exchange Transport service.

Technical Information

Steps to check if message has a improperly formatted Character Set:


1. Open Exchange Management Console.
2. In the left-pane select Toolbox.
3. In the right-pane select Message Tracking.
4. If prompted, choose whether to check for updates during startup and whether to join the Microsoft Experience Improvement Program then Go to Welcome screen.
5. Verify the EventID is set to Receive and the Start and End times cover the time of the Application Event log entry.
6. Click Next.
7. You will see a message with a subject that resembles =?ISO8859-15?Q?Subject?=.




 

 


Supplemental Materials

SourceETrack
Value2080940

Legacy ID



2010070113472554


Article URL http://www.symantec.com/docs/TECH134605


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