Login failed for user because of invalid connection string attribute

Article:TECH13512  |  Created: 2006-04-13  |  Updated: 2007-07-19  |  Article URL http://www.symantec.com/docs/TECH13512
Article Type
Technical Solution


Issue



When testing the connection for Wise Integration Component, I receive the error "Login failed for user WiseSvc Ole DB invalid connection string attribute."

Environment



Wise Package Studio 6.01
Wise Integration Component 6.1.126

Cause



When connecting to the Wise Software Manager Database, we look at the config.ini file in the share point and use the values in the ServiceSqlUser and ServiceSqlPassword fields to connect to the database.

The ServiceSqlPassword field contains the encrypted value of the password. This error message occurs if the actual password in SQL and the decrypted password do not match.

Solution



In the event that the encrypted password and the actual password got out of synch, you can reset the password by doing the following:
  1. Open Wise Repository Manager.
  2. Click on Databases > Wise Services > Wise Services Database.
  3. Click the Settings button in the lower-right corner.
  4. On the Change Database Settings dialog, either select Windows NT authentication from the first set of radio buttons if your Windows login is a DBA on your SQL Server or select SQL Server Authentication and specify the user name and password of a SQL DBA.
  5. Click Next.
  6. Specify a new password in the Password field. This will update the config.ini to have the correct encrypted password. It will also change the password on the SQL server to the password specified.

Legacy ID



21758


Article URL http://www.symantec.com/docs/TECH13512


Terms of use for this information are found in Legal Notices