Restoring COM+ Applications catalog when it is suspected of being corrupt and not allowing a full installation of Backup Exec System Recovery/Symantec System Recovery.
| Article:TECH135181 | | | Created: 2010-01-13 | | | Updated: 2011-09-23 | | | Article URL http://www.symantec.com/docs/TECH135181 |
Problem
Restoring COM+ Applications catalog when it is suspected of being corrupt and not allowing a full installation of Backup Exec System Recovery/Symantec System Recovery.
Error
Failed to have success running UninstallVssProvider Function in MSIUninstallVSSProvider Function
Cause
This can be caused by a faulty upgrade from a previous version of the software, after an upgrade of an operating system, after a deployment of an image to another computer, etc.
Solution
Follow these steps:
- If using Window 7 Home or Windows Vista Home, you must be logged into the ADMINISTRATOR account. To do this:
- Open a command prompt by clicking the Start button.
- Type CMD. Right-mouse click on the CMD or Command Prompt that appears in the box, and choose “Run as administrator”. (or use the Ctrl+Shift+Enter shortcut from the search box)
- Now type the following command: net user administrator /active:yes
- You should see a message that the command completed successfully. Log out, and you’ll now see the Administrator account as a choice. You’ll note that there’s no password for this account, so if you want to leave it enabled you should change the password.
- Uninstall Backup Exec System Recovery (BESR) or Symantec System Recovery from the control panel.
- Reboot.
- Click the start button, and type DCOMCNFG. In the left pane of the windows that open up, expand Console Root > Component Services > Computers > My Computer.
- Click on COM+ Applications. In the right-pane, you should see ‘Symantec SymSnap VSS Provider’. Right-click on that file and select DELETE. You may get an error. Ignore it.
- Download the attached Com_Fix.zip file.
- On the root of the system drive, create a folder and name it comfix (i.e., C:\comfix)
- Extract the contents of the Com_Fix.zip file to this newly created folder.
- Browse to the C:\comfix folder
- Right-mouse click on the com_fix.bat and select "Run As Administrator"
- Once the file has run successfully, restart the computer.
- Log into the ADMINISTRATOR account.
- Reinstall BESR or SSR.
- Once the software is installed succesfully, disable the ADMINISTRATOR account (if desired) by logging back into your original account and repeating step 3 and 4 by typing net user administrator /active:no.
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Legacy ID
357504
Article URL http://www.symantec.com/docs/TECH135181
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