Restoring COM+ Applications catalog when it is suspected of being corrupt and not allowing a full installation of Backup Exec System Recovery/Symantec System Recovery.

Article:TECH135181  |  Created: 2010-01-13  |  Updated: 2014-05-15  |  Article URL http://www.symantec.com/docs/TECH135181
Article Type
Technical Solution


Environment

Issue



Restoring COM+ Applications catalog when it is suspected of being corrupt and not allowing a full installation of Backup Exec System Recovery/Symantec System Recovery.


Error



Failed to have success running UninstallVssProvider Function in MSIUninstallVSSProvider Function


Cause



This can be caused by a faulty upgrade from a previous version of the software, after an upgrade of an operating system, after a deployment of an image to another computer, etc.


Solution



Follow these steps:
  1. If using Window 7 Home or Windows Vista Home, you must be logged into the ADMINISTRATOR account. To do this:
  2. Open a command prompt by clicking the Start button.
  3. Type CMD. Right-mouse click on the CMD or Command Prompt that appears in the box, and choose “Run as administrator”. (or use the Ctrl+Shift+Enter shortcut from the search box)
  4. Now type the following command: net user administrator /active:yes
  5. You should see a message that the command completed successfully. Log out, and you’ll now see the Administrator account as a choice. You’ll note that there’s no password for this account, so if you want to leave it enabled you should change the password.
  6. Uninstall Backup Exec System Recovery (BESR) or Symantec System Recovery from the control panel.
  7. Reboot.
  8. Click the start button, and type DCOMCNFG. In the left pane of the windows that open up, expand Console Root > Component Services > Computers > My Computer.
  9. Click on COM+ Applications. In the right-pane, you should see ‘Symantec SymSnap VSS Provider’. Right-click on that file and select DELETE. You may get an error. Ignore it.
  10. Download the attached Com_Fix.zip file.
  11. On the root of the system drive, create a folder and name it comfix (i.e., C:\comfix)
  12. Extract the contents of the Com_Fix.zip file to this newly created folder.
  13. Browse to the C:\comfix folder
  14. Right-mouse click on the com_fix.bat and select "Run As Administrator"
  15. Once the file has run successfully, restart the computer.
  16. Log into the ADMINISTRATOR account.
  17. Reinstall BESR or SSR.
  18. Once the software is installed succesfully, disable the ADMINISTRATOR account (if desired) by logging back into your original account and repeating step 3 and 4 by typing net user administrator /active:no.

 


Attachments

COM_Fix_357504.zip (1 kBytes)


Legacy ID



357504


Article URL http://www.symantec.com/docs/TECH135181


Terms of use for this information are found in Legal Notices