Unable to delete an Archive because of a Vault Interest entry.

Article:TECH135238  |  Created: 2010-01-12  |  Updated: 2014-08-13  |  Article URL http://www.symantec.com/docs/TECH135238
Article Type
Technical Solution

Product(s)

Issue



Unable to delete an Archive because of a Vault Interest entry.

 


Cause



Starting with Enterprise Vault (EV) 8.0 SP2, a Table has been added in the EnterpriseVaultDirectory Database called VaultInterest.  Both Compliance Accelerator (CA) and Discovery Accelerator (DA) will register an interest in an Archive by default under either of the following conditions:

  • Items in the Archive appear in the results of a CA or DA search.
  • Items in the Archive are in a CA or DA review set.

CA or DA searches will have the associated Archives listed in the VaultInterest table. This function was added to prevent an Administrator from deleting Archives without proper consent of the team(s) responsible for the contents of the searches.  Deleting an Archive that contains items captured by a CA or DA search will cause the preview and export of those items to fail.

As noted, the default behavior is to register an interest when items in an Archive are captured by a CA or DA search.  This behavior is configurable. See the following articles in the Related Articles section of this document:

  • For CA 11.0.x - HOWTO95885
  • For CA 10.0.x - HOWTO58597
  • For DA 11.0.x - HOWTO96098
  • For DA 10.0.x - HOWTO58818

 


Solution



To determine which CA Departments or DA Cases have an interest in an Archive:

  1. Open the EV Administration Console.
  2. Browse to the Console Root > Enterprise Vault folder > Directory on ... folder > [Site name] folder (i.e., evsite) > Archives folder > Archive host group folder (i.e., Exchange Mailbox, Exchange Journal, Domino Journal, Domino Mailbox).
  3. Right-click the on the name of the Archive that cannot be deleted.
  4. Select the Properties option.
  5. Click on the Advanced tab.
  6. Copy the Archive ID near the bottom of the Advanced tab.
  7. Replace Archive_ID in the SQL query below with the Archive ID found above (be sure to retain the single quotes).
  8. Run the query against the CA or DA customer database:

SELECT DISTINCT tc.[Name]
FROM tblCase  AS tc
JOIN tblIntDiscoveredItems AS tidi
  ON tidi.CaseID = tc.CaseID
JOIN tblVaults AS tv
  ON tv.VaultID = tidi.VaultID
WHERE tv.KVSVaultEntryID = 'Archive_ ID';
 

If the results show any DA Cases or CA Departments, those Cases/Departments have the Archive listed in the VaultInterest table. To delete an Archive that has been registered in the VaultInterest table, an administrator would have to:

  1. obtain consent from the appropriate team (i.e., the Legal Department) to perform the Archive deletion
  2. obtain the list of Cases/Departments with an interest in the Archive (as above)
  3. delete the Cases/Departments with an interest in the Archive.

Once deleted, allow the normal housekeeping routines to remove any relevant records from the VaultInterest table (typically 24 hours). Only then can the Archive be deleted via the normal EV processes.

 




Legacy ID



357432


Article URL http://www.symantec.com/docs/TECH135238


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