Virtual machine backups failing with errors "Final Error 0x8004230f (2147754767)" and "VSS Snapshot error. The Microsoft Volume Shadow Copy Service (VSS) snapshot provider selected returned: 'Unexpected provider error'." when multiple VSS providers are installed.

Article:TECH136047  |  Created: 2010-01-18  |  Updated: 2011-11-04  |  Article URL http://www.symantec.com/docs/TECH136047
Article Type
Technical Solution

Product(s)

Issue



Backups fail with errors "Final Error 0x8004230f (2147754767)" and "VSS Snapshot error. The Microsoft Volume Shadow Copy Service (VSS) snapshot provider selected returned: 'Unexpected provider error." This occurs when you have another provider that has faulty registration in the registry.  Typically caused by multiple backup software being installed with proprietary VSS Providers.

 

SYMPTOMS:

·          Very long VSS snapshot generation time.

·          VSS errors in the Application log in Windows Event viewer

·          VSS snapshot/quiesce errors in Backup Exec job log


Error



Job Log Errors:

 

V-79-32772-8975 - Final Error 0x8004230f (2147754767)

V-79-10000-11226 - VSS Snapshot error. The Microsoft Volume Shadow Copy Service (VSS) snapshot provider selected returned: "Unexpected provider error". Ensure that all provider services are enabled and can be started. Check Windows Event Viewer

 

Windows Event Viewer Errors:

* Check application event log on the system backed up

 

Log Name:      Application
Source:        VSS
Event ID:      22
Level:         Error
Description:  Volume Shadow Copy Service error: A critical component required by the Volume Shadow Copy service is not registered.  This might happened if an error occurred during Windows setup or during installation of a Shadow Copy provider.  The error returned from CoCreateInstance on class with CLSID <GUID> and Name <name> is [0x80040154, Class not registered].

Log Name:      Application
Source:        VSS
Event ID:      12292
Level:         Error
Description:  Volume Shadow Copy Service error: Error creating the Shadow Copy Provider COM class with CLSID <GUID>   [0x80040154, Class not registered].


Environment



Windows Server 2003
Windows Server 2003 R2
Windows Server 2008
Windows Server 2008 R2


Cause



This error is caused by a faulty VSS provider. If you have additional backup software installed or have recently uninstalled another backup software, follow the steps below to remove the snapshot provider associated with that software.


Solution



Perform the steps below on the system showing the event errors above.  Make sure that this is not caused by the Microsoft provider as deleting the registry key for that will cause all VSS to stop functioning and Microsoft will need to be contacted to resolve.
 

1.     Open the Registry Editor (Start -> Run -> enter "regedit", hit enter)

       

Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.

 

2.     Navigate to the entry HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\VSS\Providers

 

3.     (optional) Right-click on the entry with the GUID referenced in the event log and export it to a file so there is a backup.

 

4.      Delete the tree with the GUID  referenced in the event log.

 

5.     (optional but recommended) Open the Command Prompt with administrator rights (Start -> All programs -> Accessories -> Right click on Command Prompt and select Run as Administrator) and enter: vssadmin delete shadows /all  to clean up any dead VSS snapshots that may be slowing down the machine

 

6.     Reboot


Supplemental Materials

SourceUMI
ValueV-79-32772-8975
Description

Final Error 0x8004230f (2147754767)


SourceUMI
ValueV-79-10000-11226
Description

VSS Snapshot error. The Microsoft Volume Shadow Copy Service (VSS) snapshot provider selected returned: "Unexpected provider error". Ensure that all provider services are enabled and can be started. Check Windows Event Viewer.


SourceEvent ID
Value22
Description

Log Name:      Application
Source:        VSS
Level:         Error
Description:  Volume Shadow Copy Service error: A critical component required by the Volume Shadow Copy service is not registered.  This might happened if an error occurred during Windows setup or during installation of a Shadow Copy provider.  The error returned from CoCreateInstance on class with CLSID <GUID> and Name <name> is [0x80040154, Class not registered].


SourceEvent ID
Value12292
Description

Log Name:      Application
Source:        VSS
Level:         Error
Description:  Volume Shadow Copy Service error: Error creating the Shadow Copy Provider COM class with CLSID <GUID>   [0x80040154, Class not registered].


SourceError Code
Value0x8004230f
Description

VSS Snapshot error. The Microsoft Volume Shadow Copy Service (VSS) snapshot provider selected returned: 'Unexpected provider error'


Legacy ID



355843


Article URL http://www.symantec.com/docs/TECH136047


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