After upgrading from SF 5.0MP3 to SF 5.1 the upgrade removes the VRTSpbx and VRTSicsco packages which are necessary for Netbackup to function.

Article:TECH136354  |  Created: 2010-01-10  |  Updated: 2010-01-01  |  Article URL http://www.symantec.com/docs/TECH136354
Article Type
Technical Solution

Product(s)

Environment

Issue



After upgrading from SF 5.0MP3 to SF 5.1 the upgrade removes the VRTSpbx and VRTSicsco packages which are necessary for Netbackup to function.

Solution




The Cross Platform Installer (CPI) has two checks to determine package dependency for VRTSpbx and VRTSicsco packages for Netbackup.
In some cases both these checks can fail thereby making Netbackup non functional.

Root cause.

1) CPI looks at /var/sadm/pkg/install/depend file to check dependencies. It expects a space after the package name. In the case of VRTSnetb, there is a tab instead. This causes the dependency check to fail.

2) CPI also looks at /usr/openv/netbackup/version to determine if NBU is installed. In some cases /usr/openv/netbackup is under VxFS and is unmounted prior to the upgrade. CPI will now not find this file.



Possible workarounds prior to running the upgrade:

1)

# mkdir –p /usr/openv/netbackup/bin
#  touch /usr/openv/netbackup/bin/version

This should be removed after the upgrade.

OR

2)

Put a space after VRTSnetbp in /var/sadm/pkg/VRTSnetbp/install/depend




Legacy ID



355420


Article URL http://www.symantec.com/docs/TECH136354


Terms of use for this information are found in Legal Notices